[IPython-User] . Re: setting ipython3 to use python3.3 and is uninstalling existing v. necessary to use git version? (MinRK)

Matthias BUSSONNIER bussonniermatthias@gmail....
Sun Apr 14 15:13:55 CDT 2013


Le 14 avr. 2013 à 20:30, Dennis Daniels a écrit :
> My environment: linux mint 13
> I did the git install as suggested but when I run IPython it still comes up as 0.13
> ipython3 --version
> 0.13
> not the freshly installed dev version
> (Here's the install video: http://youtu.be/JK1XxsjeSNQ)
> How do I call IPython Dev explicitly? 

As usual, when you call ipython3 from the command line, 
the system will launch the first command it finds in your PATH that matches. 
Which seem to be the one you installed in another way, probably through apt-get or
equivalent if you'r running mint. 

I don't know the specific patches or what has been done for this install, 
and you most probably have partly overwritten some files when you ran 

sudo python3.3 setup.py install. 

You said that you didn't know why you had permission issue and so you ran the command with sudo. 
I suggest you not to use sudo when you don't know what you are doing or why you have some issues, 
sudo is not to be used just to force things to work, it actually means "I know what I am doing, just leave me do it", 
If you don't know what you are doing, don't sudo. 

The permission warning where **normal**, you where just trying to install files on places that are usually
reserved to the system and to be managed with apt-get. 

I guess the best thing to do is to uninstall IPython dev, uninstall the other IPython the way it need to be. 
No clue how, depends how you installed it. and clean up everything. 

Then reinstall IPython. Still those things seem to be too complicated and if you have issues with it, 
I suggest for you to stay on stable branch and rely on distribution packages for now. 

Finding why a specific version of a program is runned is not IPython specific.
You can as usual and as on any unix-y system use the common methods of 
`which` to know to which file a command point to, and examine your `PATH` and `PYTHONPATH`
to know in which order things are searched to really determine in your case why you get what you have. 

Those are things you should be comfortable with before trying to live on the edge and trying to run
both the stable and dev version of any program, and especially on multiple python version. 

> I tried running python3.3 ipython.py in the IPython directory but it failed
> dennis@dennis-HP-Compaq-tc4400-EN356UT-ABA ~/ipython $ python3.3 ipython.py notebook

As it was already discussed, this will not work, and is expected not to work. 
Please re-read the explanation we gave at that time. 

Hope this helps, 

More information about the IPython-User mailing list