[Nipy-devel] nipype running on lenny

Christopher Burns cburns@berkeley....
Thu Jan 14 13:13:11 CST 2010


Catching up on some old emails... ;)

On Wed, Nov 25, 2009 at 6:55 PM, Yaroslav Halchenko
<lists@onerussian.com> wrote:
> BTW, is numpy >= 1.2 requirement is very strict? or it is just for
> running unittests? the problem is that lenny has only 1.1...

Numpy 1.2 adopted the nose test framework.  Nipype checks for version
1.2 when it's imported and loading the test modules.  This can be
modified to not do this on lenny.  Whether the behavior of any of the
numpy functions used in nipype have changed since numpy 1.1 and 1.2
I'm not sure, but how would we check without a functioning test suite?

Support would be difficult, we'd be releasing nipype without a test
suite and to be run with a version of numpy we haven't tested or used
nipype with.  Also, we ship a version of pynifti/brifti, which uses
numpy heavily.  Supporting numpy 1.1 seems like a difficult task.

So Yarik, is this still an issue?  A quick browse of your repo and it
doesn't look like you many any code changes to get nipype accepted as
an experimental package:
http://git.debian.org/?p=pkg-exppsy/nipype.git;a=shortlog;h=refs/heads/debian-release

This is cool:
http://packages.debian.org/source/experimental/nipype

Chris



More information about the Nipy-devel mailing list