[Nipy-devel] Fresh Debian package for Nipy: 0.1.2+20110114-1

Yaroslav Halchenko lists@onerussian....
Mon Jan 17 10:42:39 CST 2011


On Mon, 17 Jan 2011, Gael Varoquaux wrote:
> Whoot!

> Not Ubuntu 10.04? It's the LTS, IIRC, so it might be an interesting
> target.

LTS is just a bold claim from Canonical, if you considered the entire Ubuntu
including the Universe (not even talking about Multiverse), which is officially
"Unsupported" by Canonical.  Canonical provides LTS only for the core, Main,
component of the distribution.  Universe relies on the community, and
Ubuntu releases follow without proper consideration of the status of
Universe.  So, that is about the value of the "LTS" claim.

Poor 10.04 fails even to install latex (pulled in by sphinx I guess) on a
clean system.  I still allow for a chance that it is a problem on our end, but
most probably not.

Just for completeness I am attaching a build log if someone decides to
buzz Ubuntu community and request the fix for such a grave (Debian would
have not being released with such) issue.   The point of failure:

Running mktexlsr. This may take some time... done.
No packages found matching texlive-base.
dpkg: error processing tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of texlive-binaries:
 texlive-binaries depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-binaries (--configure):
 dependency problems - leaving unconfigured


Well, strictly speaking, I had an idea to provide additional backporting
patch which disables building of documentation on older releases... this should
have "resolved" this issue as well... is there demand?

-- 
=------------------------------------------------------------------=
Keep in touch                                     www.onerussian.com
Yaroslav Halchenko                 www.ohloh.net/accounts/yarikoptic
-------------- next part --------------
I: Running in no-targz mode
I: using fakeroot in build.
I: Current time: Mon Jan 17 01:20:50 EST 2011
I: pbuilder-time-stamp: 1295245250
I: copying local configuration
I: mounting /proc filesystem
I: mounting /dev/pts filesystem
I: Mounting /var/cache/pbuilder/ccache
I: policy-rc.d already exists
I: Obtaining the cached apt archive contents
I: Setting up ccache
I: Installing the build-deps
 -> Attempting to satisfy build-dependencies
 -> Creating pbuilder-satisfydepends-dummy package
Package: pbuilder-satisfydepends-dummy
Version: 0.invalid.0
Architecture: amd64
Maintainer: Debian Pbuilder Team <pbuilder-maint@lists.alioth.debian.org>
Description: Dummy package to satisfy dependencies with aptitude - created by pbuilder
 This package was created automatically by pbuilder to satisfy the
 build-dependencies of the package being currently built.
Depends: cdbs, debhelper (>= 7.0.50~), python-all-dev (>= 2.4), python-support (>= 0.6), python-scipy (>= 0.5), python-numpy (>= 1.2), python-matplotlib (>= 0.98.3), python-sphinx (>= 0.6), cython, python-nifti (>> 0.20090302), python-nose, python-sympy (>= 0.6.6), liblapack-dev, graphviz, dvipng
dpkg-deb: building package `pbuilder-satisfydepends-dummy' in `/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb'.
Selecting previously deselected package pbuilder-satisfydepends-dummy.
(Reading database ... 13667 files and directories currently installed.)
Unpacking pbuilder-satisfydepends-dummy (from .../pbuilder-satisfydepends-dummy.deb) ...
dpkg: dependency problems prevent configuration of pbuilder-satisfydepends-dummy:
 pbuilder-satisfydepends-dummy depends on cdbs; however:
  Package cdbs is not installed.
 pbuilder-satisfydepends-dummy depends on debhelper (>= 7.0.50~); however:
  Package debhelper is not installed.
 pbuilder-satisfydepends-dummy depends on python-all-dev (>= 2.4); however:
  Package python-all-dev is not installed.
 pbuilder-satisfydepends-dummy depends on python-support (>= 0.6); however:
  Package python-support is not installed.
 pbuilder-satisfydepends-dummy depends on python-scipy (>= 0.5); however:
  Package python-scipy is not installed.
 pbuilder-satisfydepends-dummy depends on python-numpy (>= 1.2); however:
  Package python-numpy is not installed.
 pbuilder-satisfydepends-dummy depends on python-matplotlib (>= 0.98.3); however:
  Package python-matplotlib is not installed.
 pbuilder-satisfydepends-dummy depends on python-sphinx (>= 0.6); however:
  Package python-sphinx is not installed.
 pbuilder-satisfydepends-dummy depends on cython; however:
  Package cython is not installed.
 pbuilder-satisfydepends-dummy depends on python-nifti (>> 0.20090302); however:
  Package python-nifti is not installed.
 pbuilder-satisfydepends-dummy depends on python-nose; however:
  Package python-nose is not installed.
 pbuilder-satisfydepends-dummy depends on python-sympy (>= 0.6.6); however:
  Package python-sympy is not installed.
 pbuilder-satisfydepends-dummy depends on liblapack-dev; however:
  Package liblapack-dev is not installed.
 pbuilder-satisfydepends-dummy depends on graphviz; however:
  Package graphviz is not installed.
 pbuilder-satisfydepends-dummy depends on dvipng; however:
  Package dvipng is not installed.
dpkg: error processing pbuilder-satisfydepends-dummy (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pbuilder-satisfydepends-dummy
Reading package lists...
Building dependency tree...
Reading state information...
Initializing package states...
Writing extended state information...
The following NEW packages will be installed:
  autoconf{a} automake{a} autotools-dev{a} bsdmainutils{a} cdbs{a} 
  cython{a} debhelper{a} defoma{a} dvipng{a} fdupes{a} file{a} 
  fontconfig{a} fontconfig-config{a} gettext{a} gettext-base{a} 
  ghostscript{a} graphviz{a} groff-base{a} gsfonts{a} html2text{a} 
  intltool{a} intltool-debian{a} libamd2.2.0{a} libatk1.0-0{a} 
  libatlas-base-dev{a} libatlas-headers{a} libatlas3gf-base{a} 
  libavahi-client3{a} libavahi-common-data{a} libavahi-common3{a} 
  libblas-dev{a} libblas3gf{a} libcairo2{a} libcroco3{a} libcups2{a} 
  libcupsimage2{a} libdatrie1{a} libdirectfb-1.2-0{a} libexpat1{a} 
  libffi5{a} libfontconfig1{a} libfreetype6{a} libgd2-noxpm{a} 
  libgfortran3{a} libgraphviz4{a} libgs8{a} libgtk2.0-0{a} 
  libgtk2.0-common{a} libhtml-parser-perl{a} libhtml-tagset-perl{a} 
  libhtml-tree-perl{a} libice6{a} libjasper1{a} libjpeg62{a} 
  libjs-jquery{a} libkpathsea5{a} liblapack-dev{a} liblapack3gf{a} 
  liblcms1{a} libltdl7{a} libmagic1{a} libnewt0.52{a} libnifti2{a} 
  libpango1.0-0{a} libpango1.0-common{a} libpaper1{a} libpixman-1-0{a} 
  libpoppler5{a} libpopt0{a} libpython2.6{a} libsm6{a} libsqlite3-0{a} 
  libsysfs2{a} libt1-5{a} libthai-data{a} libthai0{a} libtiff4{a} 
  libts-0.0-0{a} libumfpack5.4.0{a} liburi-perl{a} libwww-perl{a} 
  libx11-6{a} libx11-data{a} libxau6{a} libxaw7{a} libxcb-render-util0{a} 
  libxcb-render0{a} libxcb1{a} libxcomposite1{a} libxcursor1{a} 
  libxdamage1{a} libxdmcp6{a} libxext6{a} libxfixes3{a} libxft2{a} 
  libxi6{a} libxinerama1{a} libxml-parser-perl{a} libxml2{a} libxmu6{a} 
  libxpm4{a} libxrandr2{a} libxrender1{a} libxss1{a} libxt6{a} m4{a} 
  man-db{a} mime-support{a} neurodebian-popularity-contest{a} po-debconf{a} 
  popularity-contest{a} python{a} python-all{a} python-all-dev{a} 
  python-cairo{a} python-central{a} python-dateutil{a} python-dev{a} 
  python-docutils{a} python-gobject{a} python-jinja2{a} 
  python-matplotlib{a} python-matplotlib-data{a} python-nifti{a} 
  python-nose{a} python-numpy{a} python-pkg-resources{a} python-pygments{a} 
  python-pyparsing{a} python-roman{a} python-scipy{a} python-sphinx{a} 
  python-support{a} python-sympy{a} python-tz{a} python2.6{a} 
  python2.6-dev{a} shared-mime-info{a} tcl8.5{a} tex-common{a} 
  texlive-binaries{a} tk8.5{a} tsconf{a} ttf-dejavu-core{a} ttf-lyx{a} 
  ucf{a} whiptail{a} x11-common{a} 
The following partially installed packages will be configured:
  pbuilder-satisfydepends-dummy 
0 packages upgraded, 148 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/100MB of archives. After unpacking 356MB will be used.
Writing extended state information...
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously deselected package libmagic1.
(Reading database ... 13667 files and directories currently installed.)
Unpacking libmagic1 (from .../libmagic1_5.03-5ubuntu1_amd64.deb) ...
Selecting previously deselected package file.
Unpacking file (from .../file_5.03-5ubuntu1_amd64.deb) ...
Selecting previously deselected package html2text.
Unpacking html2text (from .../html2text_1.3.2a-14build1_amd64.deb) ...
Selecting previously deselected package libxml2.
Unpacking libxml2 (from .../libxml2_2.7.6.dfsg-1ubuntu1_amd64.deb) ...
Selecting previously deselected package libcroco3.
Unpacking libcroco3 (from .../libcroco3_0.6.2-1_amd64.deb) ...
Selecting previously deselected package gettext-base.
Unpacking gettext-base (from .../gettext-base_0.17-8ubuntu3_amd64.deb) ...
Selecting previously deselected package gettext.
Unpacking gettext (from .../gettext_0.17-8ubuntu3_amd64.deb) ...
Selecting previously deselected package intltool-debian.
Unpacking intltool-debian (from .../intltool-debian_0.35.0+20060710.1_all.deb) ...
Selecting previously deselected package po-debconf.
Unpacking po-debconf (from .../po-debconf_1.0.16_all.deb) ...
Selecting previously deselected package groff-base.
Unpacking groff-base (from .../groff-base_1.20.1-7_amd64.deb) ...
Selecting previously deselected package bsdmainutils.
Unpacking bsdmainutils (from .../bsdmainutils_8.0.1ubuntu1_amd64.deb) ...
Selecting previously deselected package man-db.
Unpacking man-db (from .../man-db_2.5.7-2_amd64.deb) ...
Selecting previously deselected package debhelper.
Unpacking debhelper (from .../debhelper_7.4.15ubuntu1_all.deb) ...
Selecting previously deselected package fdupes.
Unpacking fdupes (from .../fdupes_1.50-PR2-2build1_amd64.deb) ...
Selecting previously deselected package m4.
Unpacking m4 (from .../archives/m4_1.4.13-3_amd64.deb) ...
Selecting previously deselected package autoconf.
Unpacking autoconf (from .../autoconf_2.65-3ubuntu1_all.deb) ...
Selecting previously deselected package popularity-contest.
Unpacking popularity-contest (from .../popularity-contest_1.48ubuntu1_all.deb) ...
Selecting previously deselected package neurodebian-popularity-contest.
Unpacking neurodebian-popularity-contest (from .../neurodebian-popularity-contest_0.22~nd10.04+1_all.deb) ...
Selecting previously deselected package autotools-dev.
Unpacking autotools-dev (from .../autotools-dev_20100122.1~nd10.04+1_all.deb) ...
Selecting previously deselected package automake.
Unpacking automake (from .../automake_1%3a1.11.1-1_all.deb) ...
Selecting previously deselected package liburi-perl.
Unpacking liburi-perl (from .../liburi-perl_1.52-1_all.deb) ...
Selecting previously deselected package libhtml-tagset-perl.
Unpacking libhtml-tagset-perl (from .../libhtml-tagset-perl_3.20-2_all.deb) ...
Selecting previously deselected package libhtml-parser-perl.
Unpacking libhtml-parser-perl (from .../libhtml-parser-perl_3.64-1_amd64.deb) ...
Selecting previously deselected package libhtml-tree-perl.
Unpacking libhtml-tree-perl (from .../libhtml-tree-perl_3.23-1_all.deb) ...
Selecting previously deselected package libwww-perl.
Unpacking libwww-perl (from .../libwww-perl_5.834-1_all.deb) ...
Selecting previously deselected package libexpat1.
Unpacking libexpat1 (from .../libexpat1_2.0.1-7ubuntu1_amd64.deb) ...
Selecting previously deselected package libxml-parser-perl.
Unpacking libxml-parser-perl (from .../libxml-parser-perl_2.36-1.1build3_amd64.deb) ...
Selecting previously deselected package intltool.
Unpacking intltool (from .../intltool_0.41.0-0ubuntu1_all.deb) ...
Selecting previously deselected package cdbs.
Unpacking cdbs (from .../cdbs_0.4.62+nmu1ubuntu9_all.deb) ...
Selecting previously deselected package mime-support.
Unpacking mime-support (from .../mime-support_3.48-1ubuntu1_all.deb) ...
Selecting previously deselected package libsqlite3-0.
Unpacking libsqlite3-0 (from .../libsqlite3-0_3.6.22-1_amd64.deb) ...
Selecting previously deselected package python2.6.
Unpacking python2.6 (from .../python2.6_2.6.5-1ubuntu6_amd64.deb) ...
Selecting previously deselected package python.
Unpacking python (from .../python_2.6.5-0ubuntu1_all.deb) ...
Selecting previously deselected package python-all.
Unpacking python-all (from .../python-all_2.6.5-0ubuntu1_all.deb) ...
Selecting previously deselected package libpython2.6.
Unpacking libpython2.6 (from .../libpython2.6_2.6.5-1ubuntu6_amd64.deb) ...
Selecting previously deselected package python2.6-dev.
Unpacking python2.6-dev (from .../python2.6-dev_2.6.5-1ubuntu6_amd64.deb) ...
Selecting previously deselected package python-dev.
Unpacking python-dev (from .../python-dev_2.6.5-0ubuntu1_all.deb) ...
Selecting previously deselected package python-all-dev.
Unpacking python-all-dev (from .../python-all-dev_2.6.5-0ubuntu1_all.deb) ...
Selecting previously deselected package python-support.
Unpacking python-support (from .../python-support_1.0.4ubuntu1_all.deb) ...
Selecting previously deselected package python-central.
Unpacking python-central (from .../python-central_0.6.15ubuntu1_all.deb) ...
Selecting previously deselected package libgfortran3.
Unpacking libgfortran3 (from .../libgfortran3_4.4.3-4ubuntu5_amd64.deb) ...
Selecting previously deselected package libblas3gf.
Unpacking libblas3gf (from .../libblas3gf_1.2-2build1_amd64.deb) ...
Selecting previously deselected package libatlas3gf-base.
Unpacking libatlas3gf-base (from .../libatlas3gf-base_3.6.0-24ubuntu1_amd64.deb) ...
Selecting previously deselected package liblapack3gf.
Unpacking liblapack3gf (from .../liblapack3gf_3.2.1-2_amd64.deb) ...
Selecting previously deselected package python-numpy.
Unpacking python-numpy (from .../python-numpy_1%3a1.3.0-3build1_amd64.deb) ...
Selecting previously deselected package libamd2.2.0.
Unpacking libamd2.2.0 (from .../libamd2.2.0_1%3a3.4.0-1ubuntu3_amd64.deb) ...
Selecting previously deselected package libumfpack5.4.0.
Unpacking libumfpack5.4.0 (from .../libumfpack5.4.0_1%3a3.4.0-1ubuntu3_amd64.deb) ...
Selecting previously deselected package python-scipy.
Unpacking python-scipy (from .../python-scipy_0.7.0-2_amd64.deb) ...
Selecting previously deselected package libsysfs2.
Unpacking libsysfs2 (from .../libsysfs2_2.1.0-6_amd64.deb) ...
Selecting previously deselected package tsconf.
Unpacking tsconf (from .../tsconf_1.0-7build1_all.deb) ...
Selecting previously deselected package libts-0.0-0.
Unpacking libts-0.0-0 (from .../libts-0.0-0_1.0-7build1_amd64.deb) ...
Selecting previously deselected package libdirectfb-1.2-0.
Unpacking libdirectfb-1.2-0 (from .../libdirectfb-1.2-0_1.2.8-5ubuntu2_amd64.deb) ...
Selecting previously deselected package libfreetype6.
Unpacking libfreetype6 (from .../libfreetype6_2.3.11-1ubuntu2_amd64.deb) ...
Selecting previously deselected package ucf.
Unpacking ucf (from .../archives/ucf_3.0025_all.deb) ...
Moving old data out of the way
Selecting previously deselected package ttf-dejavu-core.
Unpacking ttf-dejavu-core (from .../ttf-dejavu-core_2.30-2_all.deb) ...
Selecting previously deselected package fontconfig-config.
Unpacking fontconfig-config (from .../fontconfig-config_2.8.0-2ubuntu1_all.deb) ...
Selecting previously deselected package libfontconfig1.
Unpacking libfontconfig1 (from .../libfontconfig1_2.8.0-2ubuntu1_amd64.deb) ...
Selecting previously deselected package libpixman-1-0.
Unpacking libpixman-1-0 (from .../libpixman-1-0_0.16.4-1ubuntu2_amd64.deb) ...
Selecting previously deselected package libxau6.
Unpacking libxau6 (from .../libxau6_1%3a1.0.5-1_amd64.deb) ...
Selecting previously deselected package libxdmcp6.
Unpacking libxdmcp6 (from .../libxdmcp6_1%3a1.0.3-1_amd64.deb) ...
Selecting previously deselected package libxcb1.
Unpacking libxcb1 (from .../libxcb1_1.5-2_amd64.deb) ...
Selecting previously deselected package libx11-data.
Unpacking libx11-data (from .../libx11-data_2%3a1.3.2-1ubuntu3_all.deb) ...
Selecting previously deselected package libx11-6.
Unpacking libx11-6 (from .../libx11-6_2%3a1.3.2-1ubuntu3_amd64.deb) ...
Selecting previously deselected package libxcb-render0.
Unpacking libxcb-render0 (from .../libxcb-render0_1.5-2_amd64.deb) ...
Selecting previously deselected package libxcb-render-util0.
Unpacking libxcb-render-util0 (from .../libxcb-render-util0_0.3.6-1build1_amd64.deb) ...
Selecting previously deselected package libxrender1.
Unpacking libxrender1 (from .../libxrender1_1%3a0.9.5-1_amd64.deb) ...
Selecting previously deselected package libcairo2.
Unpacking libcairo2 (from .../libcairo2_1.8.10-2ubuntu1_amd64.deb) ...
Selecting previously deselected package python-cairo.
Unpacking python-cairo (from .../python-cairo_1.8.8-1_amd64.deb) ...
Selecting previously deselected package python-dateutil.
Unpacking python-dateutil (from .../python-dateutil_1.4.1-3_all.deb) ...
Selecting previously deselected package libffi5.
Unpacking libffi5 (from .../libffi5_3.0.9-1_amd64.deb) ...
Selecting previously deselected package python-gobject.
Unpacking python-gobject (from .../python-gobject_2.21.1-0ubuntu3_amd64.deb) ...
Selecting previously deselected package libnewt0.52.
Unpacking libnewt0.52 (from .../libnewt0.52_0.52.10-5ubuntu1_amd64.deb) ...
Selecting previously deselected package libpopt0.
Unpacking libpopt0 (from .../libpopt0_1.15-1_amd64.deb) ...
Selecting previously deselected package whiptail.
Unpacking whiptail (from .../whiptail_0.52.10-5ubuntu1_amd64.deb) ...
Selecting previously deselected package defoma.
Unpacking defoma (from .../defoma_0.11.10-4ubuntu1_all.deb) ...
Selecting previously deselected package ttf-lyx.
Unpacking ttf-lyx (from .../ttf-lyx_1.6.5-1ubuntu1_all.deb) ...
Selecting previously deselected package python-matplotlib-data.
Unpacking python-matplotlib-data (from .../python-matplotlib-data_0.99.1.2-3ubuntu1_all.deb) ...
Selecting previously deselected package python-pyparsing.
Unpacking python-pyparsing (from .../python-pyparsing_1.5.2-1ubuntu1_all.deb) ...
Selecting previously deselected package python-tz.
Unpacking python-tz (from .../python-tz_2010b-1_all.deb) ...
Selecting previously deselected package libatk1.0-0.
Unpacking libatk1.0-0 (from .../libatk1.0-0_1.30.0-0ubuntu2_amd64.deb) ...
Selecting previously deselected package libgtk2.0-common.
Unpacking libgtk2.0-common (from .../libgtk2.0-common_2.20.0-0ubuntu4_all.deb) ...
Selecting previously deselected package libavahi-common-data.
Unpacking libavahi-common-data (from .../libavahi-common-data_0.6.25-1ubuntu6_amd64.deb) ...
Selecting previously deselected package libavahi-common3.
Unpacking libavahi-common3 (from .../libavahi-common3_0.6.25-1ubuntu6_amd64.deb) ...
Selecting previously deselected package libavahi-client3.
Unpacking libavahi-client3 (from .../libavahi-client3_0.6.25-1ubuntu6_amd64.deb) ...
Selecting previously deselected package libcups2.
Unpacking libcups2 (from .../libcups2_1.4.3-1_amd64.deb) ...
Selecting previously deselected package libjpeg62.
Unpacking libjpeg62 (from .../libjpeg62_6b-15ubuntu1_amd64.deb) ...
Selecting previously deselected package libjasper1.
Unpacking libjasper1 (from .../libjasper1_1.900.1-7_amd64.deb) ...
Selecting previously deselected package fontconfig.
Unpacking fontconfig (from .../fontconfig_2.8.0-2ubuntu1_amd64.deb) ...
Selecting previously deselected package libpango1.0-common.
Unpacking libpango1.0-common (from .../libpango1.0-common_1.28.0-0ubuntu2_all.deb) ...
Selecting previously deselected package libdatrie1.
Unpacking libdatrie1 (from .../libdatrie1_0.2.2-3_amd64.deb) ...
Selecting previously deselected package libthai-data.
Unpacking libthai-data (from .../libthai-data_0.1.13-1build1_all.deb) ...
Selecting previously deselected package libthai0.
Unpacking libthai0 (from .../libthai0_0.1.13-1build1_amd64.deb) ...
Selecting previously deselected package libxft2.
Unpacking libxft2 (from .../libxft2_2.1.14-1ubuntu1_amd64.deb) ...
Selecting previously deselected package libpango1.0-0.
Unpacking libpango1.0-0 (from .../libpango1.0-0_1.28.0-0ubuntu2_amd64.deb) ...
Selecting previously deselected package libtiff4.
Unpacking libtiff4 (from .../libtiff4_3.9.2-2_amd64.deb) ...
Selecting previously deselected package libxext6.
Unpacking libxext6 (from .../libxext6_2%3a1.1.1-2_amd64.deb) ...
Selecting previously deselected package libxfixes3.
Unpacking libxfixes3 (from .../libxfixes3_1%3a4.0.4-1_amd64.deb) ...
Selecting previously deselected package libxcomposite1.
Unpacking libxcomposite1 (from .../libxcomposite1_1%3a0.4.1-1_amd64.deb) ...
Selecting previously deselected package libxcursor1.
Unpacking libxcursor1 (from .../libxcursor1_1%3a1.1.10-1_amd64.deb) ...
Selecting previously deselected package libxdamage1.
Unpacking libxdamage1 (from .../libxdamage1_1%3a1.1.2-1_amd64.deb) ...
Selecting previously deselected package libxi6.
Unpacking libxi6 (from .../libxi6_2%3a1.3-3_amd64.deb) ...
Selecting previously deselected package libxinerama1.
Unpacking libxinerama1 (from .../libxinerama1_2%3a1.1-2_amd64.deb) ...
Selecting previously deselected package libxrandr2.
Unpacking libxrandr2 (from .../libxrandr2_2%3a1.3.0-3_amd64.deb) ...
Selecting previously deselected package shared-mime-info.
Unpacking shared-mime-info (from .../shared-mime-info_0.71-1ubuntu2_amd64.deb) ...
Selecting previously deselected package libgtk2.0-0.
Unpacking libgtk2.0-0 (from .../libgtk2.0-0_2.20.0-0ubuntu4_amd64.deb) ...
Selecting previously deselected package tcl8.5.
Unpacking tcl8.5 (from .../tcl8.5_8.5.8-2_amd64.deb) ...
Selecting previously deselected package x11-common.
Unpacking x11-common (from .../x11-common_1%3a7.5+5ubuntu1_all.deb) ...
Selecting previously deselected package libxss1.
Unpacking libxss1 (from .../libxss1_1%3a1.2.0-2_amd64.deb) ...
Selecting previously deselected package tk8.5.
Unpacking tk8.5 (from .../tk8.5_8.5.8-1_amd64.deb) ...
Selecting previously deselected package python-matplotlib.
Unpacking python-matplotlib (from .../python-matplotlib_0.99.1.2-3ubuntu1_amd64.deb) ...
Selecting previously deselected package python-roman.
Unpacking python-roman (from .../python-roman_0.6-3_all.deb) ...
Selecting previously deselected package python-docutils.
Unpacking python-docutils (from .../python-docutils_0.6-3_all.deb) ...
Selecting previously deselected package python-pygments.
Unpacking python-pygments (from .../python-pygments_1.2.2+dfsg-1ubuntu1_all.deb) ...
Selecting previously deselected package python-jinja2.
Unpacking python-jinja2 (from .../python-jinja2_2.3.1-1_amd64.deb) ...
Selecting previously deselected package libjs-jquery.
Unpacking libjs-jquery (from .../libjs-jquery_1.3.3-2ubuntu1_all.deb) ...
Selecting previously deselected package python-sphinx.
Unpacking python-sphinx (from .../python-sphinx_1.0.1-1~nd10.04+1_all.deb) ...
Selecting previously deselected package cython.
Unpacking cython (from .../cython_0.13-1~nd10.04+1_amd64.deb) ...
Selecting previously deselected package libnifti2.
Unpacking libnifti2 (from .../libnifti2_2.0.0-1~lucid.nd1_amd64.deb) ...
Selecting previously deselected package python-nifti.
Unpacking python-nifti (from .../python-nifti_0.20100607.1-2~lucid.nd1_amd64.deb) ...
Selecting previously deselected package python-pkg-resources.
Unpacking python-pkg-resources (from .../python-pkg-resources_0.6.10-4ubuntu1_all.deb) ...
Selecting previously deselected package python-nose.
Unpacking python-nose (from .../python-nose_0.11.1-1_all.deb) ...
Selecting previously deselected package python-sympy.
Unpacking python-sympy (from .../python-sympy_0.6.7-1.1~nd10.04+1_all.deb) ...
Selecting previously deselected package libblas-dev.
Unpacking libblas-dev (from .../libblas-dev_1.2-2build1_amd64.deb) ...
Selecting previously deselected package libatlas-headers.
Unpacking libatlas-headers (from .../libatlas-headers_3.6.0-24ubuntu1_all.deb) ...
Selecting previously deselected package libatlas-base-dev.
Unpacking libatlas-base-dev (from .../libatlas-base-dev_3.6.0-24ubuntu1_amd64.deb) ...
Selecting previously deselected package liblapack-dev.
Unpacking liblapack-dev (from .../liblapack-dev_3.2.1-2_amd64.deb) ...
Selecting previously deselected package libgd2-noxpm.
Unpacking libgd2-noxpm (from .../libgd2-noxpm_2.0.36~rc1~dfsg-3.1ubuntu1_amd64.deb) ...
Selecting previously deselected package libltdl7.
Unpacking libltdl7 (from .../libltdl7_2.2.6b-2ubuntu1_amd64.deb) ...
Selecting previously deselected package libgraphviz4.
Unpacking libgraphviz4 (from .../libgraphviz4_2.20.2-8ubuntu3_amd64.deb) ...
Selecting previously deselected package libice6.
Unpacking libice6 (from .../libice6_2%3a1.0.6-1_amd64.deb) ...
Selecting previously deselected package libsm6.
Unpacking libsm6 (from .../libsm6_2%3a1.1.1-1_amd64.deb) ...
Selecting previously deselected package libxt6.
Unpacking libxt6 (from .../libxt6_1%3a1.0.7-1_amd64.deb) ...
Selecting previously deselected package libxmu6.
Unpacking libxmu6 (from .../libxmu6_2%3a1.0.5-1_amd64.deb) ...
Selecting previously deselected package libxpm4.
Unpacking libxpm4 (from .../libxpm4_1%3a3.5.8-1_amd64.deb) ...
Selecting previously deselected package libxaw7.
Unpacking libxaw7 (from .../libxaw7_2%3a1.0.7-1_amd64.deb) ...
Selecting previously deselected package graphviz.
Unpacking graphviz (from .../graphviz_2.20.2-8ubuntu3_amd64.deb) ...
Selecting previously deselected package libkpathsea5.
Unpacking libkpathsea5 (from .../libkpathsea5_2009-5_amd64.deb) ...
Selecting previously deselected package libt1-5.
Unpacking libt1-5 (from .../libt1-5_5.1.2-3build1_amd64.deb) ...
Selecting previously deselected package liblcms1.
Unpacking liblcms1 (from .../liblcms1_1.18.dfsg-1ubuntu2_amd64.deb) ...
Selecting previously deselected package libpoppler5.
Unpacking libpoppler5 (from .../libpoppler5_0.12.4-0ubuntu4_amd64.deb) ...
Selecting previously deselected package tex-common.
Unpacking tex-common (from .../tex-common_2.06_all.deb) ...
Selecting previously deselected package texlive-binaries.
Unpacking texlive-binaries (from .../texlive-binaries_2009-5_amd64.deb) ...
Selecting previously deselected package libcupsimage2.
Unpacking libcupsimage2 (from .../libcupsimage2_1.4.3-1_amd64.deb) ...
Selecting previously deselected package libpaper1.
Unpacking libpaper1 (from .../libpaper1_1.1.23+nmu1build1_amd64.deb) ...
Selecting previously deselected package libgs8.
Unpacking libgs8 (from .../libgs8_8.71.dfsg.1-0ubuntu5_amd64.deb) ...
Selecting previously deselected package gsfonts.
Unpacking gsfonts (from .../gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4_all.deb) ...
Selecting previously deselected package ghostscript.
Unpacking ghostscript (from .../ghostscript_8.71.dfsg.1-0ubuntu5_amd64.deb) ...
Selecting previously deselected package dvipng.
Unpacking dvipng (from .../dvipng_1.12-3build1_amd64.deb) ...
Setting up libmagic1 (5.03-5ubuntu1) ...

Setting up file (5.03-5ubuntu1) ...
Setting up html2text (1.3.2a-14build1) ...

Setting up libxml2 (2.7.6.dfsg-1ubuntu1) ...

Setting up libcroco3 (0.6.2-1) ...

Setting up gettext-base (0.17-8ubuntu3) ...

Setting up gettext (0.17-8ubuntu3) ...

Setting up intltool-debian (0.35.0+20060710.1) ...
Setting up po-debconf (1.0.16) ...
Setting up groff-base (1.20.1-7) ...

Setting up bsdmainutils (8.0.1ubuntu1) ...
update-alternatives: using /usr/bin/bsd-write to provide /usr/bin/write (write) in auto mode.

Setting up man-db (2.5.7-2) ...
Building database of manual pages ...

Setting up debhelper (7.4.15ubuntu1) ...
Setting up fdupes (1.50-PR2-2build1) ...
Setting up m4 (1.4.13-3) ...
Setting up autoconf (2.65-3ubuntu1) ...
Setting up popularity-contest (1.48ubuntu1) ...

Setting up neurodebian-popularity-contest (0.22~nd10.04+1) ...
Adding NeuroDebian url for Popularity Contest submissions.

Setting up autotools-dev (20100122.1~nd10.04+1) ...
Setting up automake (1:1.11.1-1) ...
update-alternatives: using /usr/bin/automake-1.11 to provide /usr/bin/automake (automake) in auto mode.

Setting up liburi-perl (1.52-1) ...
Setting up libhtml-tagset-perl (3.20-2) ...
Setting up libhtml-parser-perl (3.64-1) ...
Setting up libhtml-tree-perl (3.23-1) ...
Setting up libwww-perl (5.834-1) ...
Setting up libexpat1 (2.0.1-7ubuntu1) ...

Setting up libxml-parser-perl (2.36-1.1build3) ...
Setting up intltool (0.41.0-0ubuntu1) ...
Setting up cdbs (0.4.62+nmu1ubuntu9) ...
Setting up mime-support (3.48-1ubuntu1) ...
update-alternatives: using /usr/bin/see to provide /usr/bin/view (view) in auto mode.

Setting up libsqlite3-0 (3.6.22-1) ...

Setting up python2.6 (2.6.5-1ubuntu6) ...

Setting up python (2.6.5-0ubuntu1) ...

Setting up python-all (2.6.5-0ubuntu1) ...
Setting up libpython2.6 (2.6.5-1ubuntu6) ...

Setting up python2.6-dev (2.6.5-1ubuntu6) ...
Setting up python-dev (2.6.5-0ubuntu1) ...
Setting up python-all-dev (2.6.5-0ubuntu1) ...
Setting up python-support (1.0.4ubuntu1) ...

Setting up python-central (0.6.15ubuntu1) ...

Setting up libgfortran3 (4.4.3-4ubuntu5) ...

Setting up libblas3gf (1.2-2build1) ...

Setting up libatlas3gf-base (3.6.0-24ubuntu1) ...

Setting up liblapack3gf (3.2.1-2) ...

Setting up python-numpy (1:1.3.0-3build1) ...

Setting up libamd2.2.0 (1:3.4.0-1ubuntu3) ...

Setting up libumfpack5.4.0 (1:3.4.0-1ubuntu3) ...

Setting up libsysfs2 (2.1.0-6) ...

Setting up tsconf (1.0-7build1) ...
Setting up libts-0.0-0 (1.0-7build1) ...

Setting up libdirectfb-1.2-0 (1.2.8-5ubuntu2) ...

Setting up libfreetype6 (2.3.11-1ubuntu2) ...

Setting up ucf (3.0025) ...

Setting up ttf-dejavu-core (2.30-2) ...
Setting up fontconfig-config (2.8.0-2ubuntu1) ...

Setting up libfontconfig1 (2.8.0-2ubuntu1) ...

Setting up libpixman-1-0 (0.16.4-1ubuntu2) ...

Setting up libxau6 (1:1.0.5-1) ...

Setting up libxdmcp6 (1:1.0.3-1) ...

Setting up libxcb1 (1.5-2) ...

Setting up libx11-data (2:1.3.2-1ubuntu3) ...
Setting up libx11-6 (2:1.3.2-1ubuntu3) ...

Setting up libxcb-render0 (1.5-2) ...

Setting up libxcb-render-util0 (0.3.6-1build1) ...

Setting up libxrender1 (1:0.9.5-1) ...

Setting up libcairo2 (1.8.10-2ubuntu1) ...

Setting up python-cairo (1.8.8-1) ...

Setting up python-dateutil (1.4.1-3) ...

Setting up libffi5 (3.0.9-1) ...

Setting up python-gobject (2.21.1-0ubuntu3) ...

Setting up libnewt0.52 (0.52.10-5ubuntu1) ...

Setting up libpopt0 (1.15-1) ...

Setting up whiptail (0.52.10-5ubuntu1) ...
Setting up defoma (0.11.10-4ubuntu1) ...

Setting up ttf-lyx (1.6.5-1ubuntu1) ...

Setting up python-matplotlib-data (0.99.1.2-3ubuntu1) ...
Setting up python-pyparsing (1.5.2-1ubuntu1) ...

Setting up python-tz (2010b-1) ...

Setting up libatk1.0-0 (1.30.0-0ubuntu2) ...

Setting up libgtk2.0-common (2.20.0-0ubuntu4) ...
Setting up libavahi-common-data (0.6.25-1ubuntu6) ...
Setting up libavahi-common3 (0.6.25-1ubuntu6) ...

Setting up libavahi-client3 (0.6.25-1ubuntu6) ...

Setting up libcups2 (1.4.3-1) ...

Setting up libjpeg62 (6b-15ubuntu1) ...

Setting up libjasper1 (1.900.1-7) ...

Setting up fontconfig (2.8.0-2ubuntu1) ...
Updating font configuration of fontconfig...
Cleaning up category cid..
Cleaning up category truetype..
Cleaning up category type1..
Updating category type1..
Updating category truetype..
Updating category cid..
Updating fontconfig cache for /usr/share/fonts/truetype/ttf-lyx
Cleaning up old fontconfig caches... done.
Regenerating fonts cache... done.

Setting up libpango1.0-common (1.28.0-0ubuntu2) ...
Cleaning up font configuration of pango...
Updating font configuration of pango...
Cleaning up category xfont..
Updating category xfont..
*** You don't have any defomized font packages.
*** So we are trying to force to generate pangox.aliases...

Setting up libdatrie1 (0.2.2-3) ...

Setting up libthai-data (0.1.13-1build1) ...
Setting up libthai0 (0.1.13-1build1) ...

Setting up libxft2 (2.1.14-1ubuntu1) ...

Setting up libpango1.0-0 (1.28.0-0ubuntu2) ...

Setting up libtiff4 (3.9.2-2) ...

Setting up libxext6 (2:1.1.1-2) ...

Setting up libxfixes3 (1:4.0.4-1) ...

Setting up libxcomposite1 (1:0.4.1-1) ...

Setting up libxcursor1 (1:1.1.10-1) ...

Setting up libxdamage1 (1:1.1.2-1) ...

Setting up libxi6 (2:1.3-3) ...

Setting up libxinerama1 (2:1.1-2) ...

Setting up libxrandr2 (2:1.3.0-3) ...

Setting up shared-mime-info (0.71-1ubuntu2) ...

Setting up libgtk2.0-0 (2.20.0-0ubuntu4) ...

Setting up tcl8.5 (8.5.8-2) ...
update-alternatives: using /usr/bin/tclsh8.5 to provide /usr/bin/tclsh (tclsh) in auto mode.

Setting up x11-common (1:7.5+5ubuntu1) ...

Setting up libxss1 (1:1.2.0-2) ...

Setting up tk8.5 (8.5.8-1) ...
update-alternatives: using /usr/bin/wish8.5 to provide /usr/bin/wish (wish) in auto mode.

Setting up python-roman (0.6-3) ...

Setting up python-docutils (0.6-3) ...

Setting up python-pygments (1.2.2+dfsg-1ubuntu1) ...

Setting up python-jinja2 (2.3.1-1) ...

Setting up libjs-jquery (1.3.3-2ubuntu1) ...
Setting up python-sphinx (1.0.1-1~nd10.04+1) ...

Setting up cython (0.13-1~nd10.04+1) ...

Setting up libnifti2 (2.0.0-1~lucid.nd1) ...

Setting up python-pkg-resources (0.6.10-4ubuntu1) ...

Setting up python-sympy (0.6.7-1.1~nd10.04+1) ...

Setting up libblas-dev (1.2-2build1) ...
update-alternatives: using /usr/lib/libblas.so to provide /usr/lib/libblas-3gf.so (libblas-3gf.so) in auto mode.

Setting up libatlas-headers (3.6.0-24ubuntu1) ...
Setting up libatlas-base-dev (3.6.0-24ubuntu1) ...
update-alternatives: using /usr/lib/atlas/libblas.so to provide /usr/lib/libblas-3.so (libblas-3.so) in auto mode.
update-alternatives: using /usr/lib/atlas/liblapack.so to provide /usr/lib/liblapack-3.so (liblapack-3.so) in auto mode.

Setting up liblapack-dev (3.2.1-2) ...
update-alternatives: using /usr/lib/liblapack.so to provide /usr/lib/liblapackgf-3.so (liblapackgf-3.so) in auto mode.

Setting up libgd2-noxpm (2.0.36~rc1~dfsg-3.1ubuntu1) ...

Setting up libltdl7 (2.2.6b-2ubuntu1) ...

Setting up libgraphviz4 (2.20.2-8ubuntu3) ...

Setting up libice6 (2:1.0.6-1) ...

Setting up libsm6 (2:1.1.1-1) ...

Setting up libxt6 (1:1.0.7-1) ...

Setting up libxmu6 (2:1.0.5-1) ...

Setting up libxpm4 (1:3.5.8-1) ...

Setting up libxaw7 (2:1.0.7-1) ...

Setting up graphviz (2.20.2-8ubuntu3) ...

Setting up libkpathsea5 (2009-5) ...

Setting up libt1-5 (5.1.2-3build1) ...

Setting up liblcms1 (1.18.dfsg-1ubuntu2) ...

Setting up libpoppler5 (0.12.4-0ubuntu4) ...

Setting up tex-common (2.06) ...

Creating config file /etc/texmf/texmf.d/05TeXMF.cnf with new version

Creating config file /etc/texmf/texmf.d/15Plain.cnf with new version

Creating config file /etc/texmf/texmf.d/45TeXinputs.cnf with new version

Creating config file /etc/texmf/texmf.d/55Fonts.cnf with new version

Creating config file /etc/texmf/texmf.d/65BibTeX.cnf with new version

Creating config file /etc/texmf/texmf.d/75DviPS.cnf with new version

Creating config file /etc/texmf/texmf.d/85Misc.cnf with new version

Creating config file /etc/texmf/texmf.d/90TeXDoc.cnf with new version

Creating config file /etc/texmf/texmf.d/95NonPath.cnf with new version

Creating config file /etc/texmf/updmap.d/00updmap.cfg with new version

Creating config file /etc/texmf/texmf.cnf with new version
Running mktexlsr. This may take some time... done.
No packages found matching texlive-base.
dpkg: error processing tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of texlive-binaries:
 texlive-binaries depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-binaries (--configure):
 dependency problems - leaving unconfigured
Setting up libcupsimage2 (1.4.3-1) ...
No apport report written because the error message indicates its a followup error from a previous failure.

Setting up libpaper1 (1.1.23+nmu1build1) ...

Creating config file /etc/papersize with new version

Setting up libgs8 (8.71.dfsg.1-0ubuntu5) ...

Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4) ...
(Re-)registering PostScript fonts...
Updating fontconfig cache for /usr/share/fonts/type1/gsfonts
done.

Setting up ghostscript (8.71.dfsg.1-0ubuntu5) ...
update-alternatives: using /usr/bin/ps2pdf14 to provide /usr/bin/ps2pdf (ps2pdf) in auto mode.
Updating font configuration of gs...
Cleaning up category psprint..
Cleaning up category cmap..
Cleaning up category cid..
Cleaning up category truetype..
Cleaning up category gsfontderivative..
Cleaning up category type3..
Cleaning up category type1..
Updating category type1..
Updating category type3..
Updating category gsfontderivative..
Updating category truetype..
Updating category cid..
Updating category cmap..
Updating category psprint..

dpkg: dependency problems prevent configuration of dvipng:
 dvipng depends on texlive-base-bin; however:
  Package texlive-base-bin is not installed.
  Package texlive-binaries which provides texlive-base-bin is not configured yet.
dpkg: error processing dvipng (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pbuilder-satisfydepends-dummy:
 pbuilder-satisfydepends-dummy depends on dvipng; however:
  Package dvipng is not configured yet.
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: error processing pbuilder-satisfydepends-dummy (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Processing triggers for python-central ...
Setting up python-nifti (0.20100607.1-2~lucid.nd1) ...

Setting up python-nose (0.11.1-1) ...

Setting up python-scipy (0.7.0-2) ...
/usr/lib/python2.6/dist-packages/scipy/stats/mstats_basic.py:106: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert(output.ndim == 2, "The input should be 2D!")

Setting up python-matplotlib (0.99.1.2-3ubuntu1) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
Processing triggers for python-central ...
Errors were encountered while processing:
 tex-common
 texlive-binaries
 dvipng
 pbuilder-satisfydepends-dummy
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
No packages found matching texlive-base.
dpkg: error processing tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of texlive-binaries:
 texlive-binaries depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-binaries (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dvipng:
 dvipng depends on texlive-base-bin; however:
  Package texlive-base-bin is not installed.
  Package texlive-binaries which provides texlive-base-bin is not configured yet.
dpkg: error processing dvipng (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pbuilder-satisfydepends-dummy:
 pbuilder-satisfydepends-dummy depends on dvipng; however:
  Package dvipng is not configured yet.
dpkg: error processing pbuilder-satisfydepends-dummy (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 tex-common
 texlive-binaries
 dvipng
 pbuilder-satisfydepends-dummy
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Writing extended state information...
E: pbuilder-satisfydepends failed.
I: Copying back the cached apt archive contents
I: unmounting /var/cache/pbuilder/ccache filesystem
I: unmounting dev/pts filesystem
I: unmounting proc filesystem


More information about the Nipy-devel mailing list