[Numpy-discussion] multipack

Jim Boyle boyle5 at llnl.gov
Fri Jan 19 11:33:22 CST 2001

Thanks to Arne and Paul I took the time to find out what was going 
on. It turns out that the CVS has multipack 0.8 and Travis added the 
cephes, numpyio and sigtools modules to multipack in going from 0.7 
to 0.8. I did the usual things to account for a non-standard python 
location at the topmost level of Multipack as I had before with 0.7 
but should have also tweaked the Makefiles in the cephes, numpyio and 
sigtools directories. The result was that these modules were built 
with Python 1.5 and all the others with 2.0 and I confused myself as 
to where the problem was.

But when I tried to build the cephes module using Python 2.0 I got 
the following error:
gcc -O2 -I/usr/local/include/python2.0    -c -o amos_wrappers.o amos_wrappers.c
In file included from cephes/mconf.h:162,
                  from amos_wrappers.h:12,
                  from amos_wrappers.c:8:
cephes/protos.h:67: parse error before `sizeof'
cephes/protos.h:68: parse error before `sizeof'
cephes/protos.h:69: parse error before `sizeof'
make: *** [amos_wrappers.o] Error 1

the line:
gcc -O2 -I/usr/local/include/python1.5 -c -o amos_wrappers.o amos_wrappers.c

works fine. I have tried this on another machine with Python 2.0 and 
got the same
error. The Python.h includes changed quite a bit in going from 1.5 to 2.0.
Any ideas as to what is wrong would be welcome.
  Has anyone installed multipack 0.8 using Python 2.0?


>I install the multipack-0.7 with my new installation of Python2.0 and I
>don't have any
>warning :
>maybe a problem with PYTHONPATH if your old Multipack under your old
>Pyhon1.5 is still present?
>Jim Boyle wrote:
>>  I pulled the multipack code from the CVS server and built it for my
>>  new installation of Python 2.0.
>>  When I import Multipack I get:
>>  WARNING: Python C API version mismatch for module cephes:
>>    This Python has API version 1009, module cephes has version 1007
>>  this warning occurs for the numpyio and sigtools modules.
>>  Have I done something screwy in the installation, or do the modules
>>  have to be updated?
>>  If the latter is there any guidance on what to fix? What are the
>>  routines/procedures that changed in going from version 1007 to 1009?
>>  So far everything appears to provide the correct answers, so the API
>>  mismatch is not crippling. However, from past experience I know that
>  > ignoring warnings often ends in tears.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20010119/0fa4d6d0/attachment-0001.html 

More information about the Numpy-discussion mailing list