[Fwd: Re: [Numpy-discussion] first impressions with numpy]

Sebastian Haase haase at msg.ucsf.edu
Sun Apr 2 17:21:14 CDT 2006

supposedly meant for the whole list ...
From: Tim Hochberg <tim.hochberg at cox.net>

Sebastian Haase wrote:

> Tim Hochberg wrote:
> <snip>
>> This would work fine if repr were instead:
>>    dtype([('x', float64), ('z', complex128)])
>> Anyway, this all seems reasonable to me at first glance. That said, I 
>> don't plan to work on this, I've got other fish to fry at the moment.
> A new point: Please remind me (and probably others): when did it get 
> decided to introduce 'complex128' to mean numarray's complex64
> and the 'complex64' to mean numarray's complex32 ?

I haven't the faintest idea -- it happened when I was off in Numarray
land I assume. Or it was always that way? No idea. Hopefully Travis will
answer this.


> I do understand the logic that 128 is really the bit-size of one 
> (complex) element - but I also liked the old way, because:
> 1. e.g. in fft transforms, float32 would "go with" complex32
>    and float64 with complex64
> 2. complex128 is one character extra (longer) and also 
> (alphabetically) now sorts before(!) complex64
> 3 Mostly of course: this new naming will confuse all my code and 
> introduce hard to find bugs - when I see complex64 I will "think" the 
> old way for quite some time ...
> These might just be my personal (idiotic ;-) comments - but I would 
> appreciate some feedback/comments.
> Also: Is it now to late to (re-)start a discussion on this !?
> Thanks
> - Sebastian Haase

More information about the Numpy-discussion mailing list