[Numpy-discussion] Segmentation Fault with Numeric 24.2 on Mac OS X 10.4 Tiger (8.7.0)

Daran L. Rife drife at ucar.edu
Thu Aug 10 00:45:48 CDT 2006


I recently switched from a Debian Linux box to a Mac G5
PowerPC, running Mac OS X 10.4 Tiger (8.7.0). I use the
Python Numeric package extensively, and have come to
depend upon it. In my view, this piece of software is
truly first rate, and it has greatly improved my
productivity in the area of scientific analysis.

Unfortunately, I am experiencing a problem that I cannot sort
out. I am running Python 2.4.3 on a Debian box (V3.1), using
gcc version 4.0.1, and the Apple vecLib.framework which has
an optimized BLAS and LAPACK. When building Numeric 24.0,
24.1, or 24.2 everything seems to go AOK. But when I run
code which makes use of the Numeric package (maksed arrays,
dot product, LinearAlgebra, etc.) my code crashes hard and
unpredictably. When it crashes I simply get a "Segmentation
Fault". I'm sorry that I can't be more specific about what
seems to happen just before the crash...I've tried to trace
it but to no avail.

Interestingly, I can get Numeric version 23.8 to build and
run just fine, but it appears that the dotblas (BLAS
optimized matrixmultiply/dot/innerproduct) does not properly
get built in. Thus, all my matrix operations are -very- slow.

Has anyone seen this problem, or know where I might look
to solve it? Perhaps I have overlooked a crucial step in
the build/install of Numeric 24.x on the Mac.

I searched round the Net with google, and have sifted through
the numpy/scipy/numeric Web pages, various mailing lists, user
groups, etc., and can't seem to find any relevant info.

Alternatively, can someone explain how to get Numeric 23.8
to compile on OS X 10.4 Tiger, with the dotblas module?

Thanks very much for your help,


More information about the Numpy-discussion mailing list