[Numpy-discussion] Matlab page on scipy wiki
ndarray at mac.com
Fri Feb 10 15:16:01 CST 2006
I would be against any meaningful name because it will look too much
like a function and people will be trying to use (...) instead of
[...] with it. A single-letter identifier will look more like syntax
and the concatenator is really just a clever way to take advantage of
Python syntax that recognizes slices inside . Novices may just
think that something like c[1:3,9:20]
is an array literal like r"xyz" for raw strings (another argument against "r"!).
On 2/10/06, Eric Firing <efiring at hawaii.edu> wrote:
> Travis Oliphant wrote:
> > Christopher Barker wrote:
> >> Colin J. Williams wrote:
> >>>> numpy.r_[1,0,range(1,5),0,1]
> >>> This seems to be a neat idea but not in the usual Python style.
> >> Exactly. couldn't it at least get a meaningful, but short, name?
> > It is meaningful :-) r_ means row concatenation... (but, it has taken
> > on more functionality than that). What name do you suggest?
> "cat"? "rcat"? "catr"? "catter"?
> This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
> for problems? Stop! Download the new AJAX search engine that makes
> searching your log files as easy as surfing the web. DOWNLOAD SPLUNK!
> Numpy-discussion mailing list
> Numpy-discussion at lists.sourceforge.net
More information about the Numpy-discussion