[Numpy-discussion] Don't like the short names like lstsq and irefft
svetosch at gmx.net
Fri Jun 16 03:43:42 CDT 2006
Alexander Belopolsky schrieb:
> In my view it is more important that code is easy to read rather than
> easy to write. Interactive users will disagree, but in programming you
> write once and read/edit forever :).
The insight about this disagreement imho suggests a compromise (or call
it a dual solution): Have verbose names, but also have good default
abbreviations for those who prefer them.
It would be unfortunate if numpy users were required to cook up their
own abbreviations if they wanted to, because 1. it adds overhead, and 2.
it would make other people's code more difficult to read.
> Again, there is no defense for abbreviating linear_least_squares
> because it is unlikely to appear in an expression and waste valuable
> horisontal space.
not true imho; btw, I would suggest "ols" (ordinary least squares),
which is in every textbook.
More information about the Numpy-discussion