[Numpy-discussion] NumPy 0.9.6 and win32pdh

Ed Schofield schofield at ftw.at
Sat Mar 18 08:27:03 CST 2006

Hi all,

I'm trying to compile Win32 binaries for a new release of SciPy.  I'm
getting a warning message upon import after installing

import testing -> failed: No module named win32pdh

and I'm unable to run any of NumPy's unit tests unless I manually
comment out the block

if os.name=='nt':

in testing\utils.py.

Has anyone else seen this?  Does anyone know if the win32pdh module is
supposed to be installed with the python-2.4.2.msi installer from

The Python 2.3 installer, numpy-0.9.6-win32-py2.3.exe, works fine,
because the corresponding if statement has an additional condition ("
and sys.version[:3] > '2.3'"), so the import is never attempted.

-- Ed

More information about the Numpy-discussion mailing list