Can' compile numpy 1.02rc3 on OSX 10.3.9

markusro at markusro at
Tue Oct 24 09:54:03 CDT 2006

> Am 20.10.2006 um 02:53 schrieb Jay Parlar:
>>> Hi!
>>> I try to compile numpy rc3 on Panther and get following errors.
>>> (I start build with "python2.3 build" to be sure to use the
>>> python shipped with OS X. I din't manage to compile Python2.5 either
>>> yet with similar errors)
>>> Does anynbody has an Idea?
>>> gcc-3.3
>>> XCode 1.5
>>> November gcc updater is installed
>> I couldn't get numpy building with Python 2.5 on 10.3.9 (although I
>> had different compile errors). The solution that ended up working for
>> me was Python 2.4. There's a bug in the released version of Python 2.5
>> that's preventing it from working with numpy, should be fixed in the
>> next release.
>> You can find a .dmg for Python 2.4 here:
>> Jay P.
> I have that installed already but i get some bus errors with that.
> Furthermore it is built with gcc4
> and i need to compile an extra module(pytables) and I fear that will
> not work, hence I try to compile myself. Python 2.5 dosent't compile
> either (libSystemStubs is only on Tiger).

I have now everything compileing nicely:
Python 2.5 (removed the -llibSystemStubs from the Makefile)
the BusError when using iPython was still present; the reason is an
unpatched readline 5.1. This problem was solved by libreadline-5.2.
numpy rc3 compiled, too but numpy.test() still fails with them same error
(see previous post)


Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo

More information about the Numpy-discussion mailing list