[Numpy-discussion] problem with installation of numpy: undefined symbols

Eric Emsellem emsellem@obs.univ-lyon1...
Thu Feb 1 06:24:56 CST 2007


after trying to solve an installation problem with scipy, I had to
reinstall everything from scratch, and so I now turned back to numpy the
installation of which does not work for me (which may in fact explain
the pb I had with scipy).

To be clear on what I do:

- I install blas first, and create a libfblas.a which I copy under
(using a g77 -fno-second-underscore -O2 -c *.f, ar r libfblas.a *.o,
ranlib libfblas.a)

- I then define BLAS environment variable accordingly
- I compile lapack-3.1.0, using "make lapacklib"
- I then use a precompiled ATLAS Linux version P4SSE2 (I tried compiling
it but it does have the same result)
- I copy all ATLAS .a and .h in /usr/local/lib/atlas, and define the
ATLAS variable accordingly
- I then merge the  *.o to have an extended liblapack.a by doing the usual:
         cd /usr/local/lib/atlas
         cp liblapack.a liblapack.a_ATLAS
         mkdir tmp
         cd tmp
         ar x ../liblapack.a_ATLAS
/soft/python/tar/Science_Packages/lapack-3.1.0/lapack_LINUX.a ../liblapack.a
         ar r ../liblapack.a *.o

- I finally get the svn version of numpy, and do the "python setup.py
install" (no site.cfg ! but environment variables defined as mentioned

- I go into ipython, and try:

        import numpy

and I get :

exceptions.ImportError                               Traceback (most
recent call last)
---> 40     import linalg
undefined symbol: ATL_cGetNB

I have tried many ways to avoid this problem but does not manage to
solve it.

Any help is welcome there. (and sorry for those who already saw my
numerous posts on scipy forum: I am trying to get to the heart of the pb...)

thanks in advance!

More information about the Numpy-discussion mailing list