[Numpy-discussion] Source install

Mark Janikas mjanikas@esri....
Wed Feb 28 16:46:19 CST 2007

Thanks Robert,

Sorry for the incomplete request for help.  The install of numpy seems
to go fine, but when I import numpy it reports that it is running from
the source directory.  I assume this has to do with the BLAS/ATLAS stuff
I have been reading about.  What I am actually trying to do is get NumPy
wrapped in the install of our software program.  We currently wrap
Python2.4 as our scripting language and I need a way to get numpy in our
compiler.  The gui portions of our software runs on Windows but the
engine works on Unix flavors.  I am afraid I am not too knowledgeable
about what goes on under the hood of the NumPy install.  I assume I need
an appropriate C compiler (where gcc fit in for Mac OSX), but I was
wondering if there was an appropriate Doc I should closely examine that
would point me in the right direction.  I hope this clears my question
up a bit.  Again, thanks in advance....


-----Original Message-----
From: numpy-discussion-bounces@scipy.org
[mailto:numpy-discussion-bounces@scipy.org] On Behalf Of Robert Kern
Sent: Wednesday, February 28, 2007 11:26 AM
To: Discussion of Numerical Python
Subject: Re: [Numpy-discussion] Source install

Mark Janikas wrote:
> Hello all,
> I have used numpy on both Mac and Windows.  The latter is easily
> installed with the exe file.  The former required the gcc program from
> XCode... but once installed, "python setup.py install" worked.  I cant
> seem to get numpy to work on my linux machine.  Can someone point me
> a platform-independent doc on how to install from the source tar file?
>  Thanks ahead of time,

We need more information from you. There is no way one can make a
platform-independent doc that covers all of the cases. We need to know
what you
tried and exactly how it failed (i.e., we need you to copy the exact
messages and paste them into an email).

If I had to guess, though, since you succeeded doing an install from
source on
OS X, the problem on Linux is likely that you do not have the
appropriate Python
development package for your system. On RPM-based systems like Fedora
Core, it
is usually named something like python-devel.

Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
 that is made terrible by our own mad attempt to interpret it as though
it had
 an underlying truth."
  -- Umberto Eco
Numpy-discussion mailing list

More information about the Numpy-discussion mailing list