[Numpy-discussion] numpy.linalg.qr bug on 64-bit platforms

David M. Cooke cookedm@physics.mcmaster...
Thu Mar 8 02:27:39 CST 2007

On Mar 7, 2007, at 04:57 , Lars Bittrich wrote:

> On Monday 05 March 2007 08:01, Steffen Loeck wrote:
>> Has there been any progress in solving this problem? I get the  
>> same error
>> message and have no idea how to solve it.
> I do not understand those code parts very well but I think the  
> values passed
> to the lapack routines must be integer and not long integer on 64bit
> architecture. A few tests with the attached patch worked well.

Yeah, this problem is kind of ugly; we should have a test for the  
integer size in Fortran compilers. However, I don't know how to do  
that. We've been pretty lucky so far: INTEGER seems to be a C int on  
everything. I know this is true for GNU Fortran (g77, gfortran) on  
Linux, on both 32-bit and 64-bit platforms. But I don't think there's  
any guarantee that it would be true in general.

|David M. Cooke              http://arbutus.physics.mcmaster.ca/dmc/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://projects.scipy.org/pipermail/numpy-discussion/attachments/20070308/71398aca/attachment.bin 

More information about the Numpy-discussion mailing list