[Numpy-discussion] segfault with dot

Jesus Torrecilla Pinero jtorrecilla@gmail....
Sat Nov 17 05:01:45 CST 2007

I am using Python 2.5.1 (r251:54863, Apr 18 2007, 08:51:08) under Windows XP
and converting a program from Numeric to Numpy. If I have two arrays, say K
and T and do dot(K,T) or K*T everything goes well, but if I have a vector b
and try dot(K,b) or K*b I get a segfault.

I have tried to run the test in tes_numeric.py and get the same result.

I have tried too to convert b in a matrix with two columns, the second one
being all zeroes, and numpy makes the multiplication correctly, so I think
the problem is just with vectors

Does this happens with other versions or do you have any idea to fix this

Thanks in advance

Jesús Torrecilla Pinero
Universidad de Extremadura
jtorrecilla at utcsl.com
jtorreci at unex.es
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20071117/71fde304/attachment-0001.html 

More information about the Numpy-discussion mailing list