[Numpy-discussion] numpy build error on Solaris, No module named _md5

Gong, Shawn (Contractor) Shawn.Gong@drdc-rddc.gc...
Tue Dec 9 10:00:30 CST 2008

hi list,

I tried to build numpy 1.2.1 on Solaris 9 with gcc 3.4.6

when I typed "python setup.py build", I got error from hashlib.py
  File "/home/sgong/dev181/dist/lib/python2.5/hashlib.py", line 133, in
    md5 = __get_builtin_constructor('md5')
  File "/home/sgong/dev181/dist/lib/python2.5/hashlib.py", line 60, in
    import _md5
ImportError: No module named _md5

I then tried python 2.6.1 instead of 2.5.2, but got the same error.
I did not get the error while building on Linux. But I performed steps
on Linux:
1) copy *.a Atlas libraries to my local_install/atlas/
2) ranlib *.a
3) created a site.cfg
Do I need to do the same on Solaris?

Any help is appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20081209/38457d75/attachment.html 

More information about the Numpy-discussion mailing list