[Numpy-discussion] Singular Matrix problem with Matplitlib in Numpy (Windows - AMD64)

George Goussard gwg@emss.co...
Wed Dec 17 13:11:22 CST 2008

Hi Micheal.

I am going on vacation tomorrow. An example will have to wait until I am back,
but I can give some version information now:

Numpy is version 1.2.1, Matplotlib is version 0.98.5 and I am using
stock-standard(not the Enthought version or other distribution) Python 2.5.
My Python 2.5 I also compiled with MSVC 2005(AMD/em64t setting) because I can't
have dependecies on older crt libraries/dll's. The Intel MKL version is and the AMD ACML version is 4.2.0. I am not using both at the same
time. I have first tried the Intel one and now I am using AMD's ACML as
explained in previous email. Everything is compiled using the AMD64/em64t
"settings". I am not compiling on IA32 and IA64 etc. All the other necessary
version information(MSVC), I'll have to check when I am back at the office. 

I also use other libraries like PyQt(3.17.??) and SIP(version 4.7.7). Both of
them are the commercial versions and I also have commercial version of Qt 4.3.3.
Needless to say that my backend agg is Qt4Agg.

I have tested on Linux 64 bit (SuSe 10.?? commercial version not openSuSe) and
it worked. I also tested on Windows XP 32-bit and Linux 32-bit(SuSe 10.??) and
everything worked. 

Constructing and example won't be trivial but I'll try. The reason being thatI
embedded Python in an application and then I display graphs using SIP and PyQt.
The application was done using Qt4. Anyway, but I'll get back to you on that as
soon as I am finished with it.

Another interesting aspect is that in my application where I initially construct
the array using PyArray_SimpleNew, if I change this to, for example
PyArray_SimpleNewFromData then I get a completely different graph which is a
solid line(not the effect I described in the previous email) but it is
completely the wrong graph, with very small numbers(E-16 numbers). One thing
that also bothers me is that on Windows 32-bit. The default was not FORTRAN
arrays, but on Windows XP 64 bit the order and everything is FORTRAN default.
I ain't even using anything remotely to FORTRAN. I think the AMD ACML is
compiled using the Intel FORTRAN compiler, but will that effect it??

Anyway, I'll put an effort into constructing an example, but it will have to be
when I am back at the office from my vacation.

Cheers. Thanks.


More information about the Numpy-discussion mailing list