[Numpy-discussion] It appears that f2py fails to pass --compiler information to distutils on Windows XP

Ryan Gutenkunst rng7@cornell....
Tue Jul 15 22:39:53 CDT 2008

Hi all,

A project of mine uses f2py internally to dynamically build extension  
modules, and we've recently had problems with it on Windows XP using  
Python 2.5.2. I think I've isolated the problem to f2py passing the -- 
compiler option to distutils. It appears not to be doing so.

If I run "python c:\python25\Scripts\f2py.py -c --compiler=mingw32" I  
get the message:
running build
running scons
No module named msvccompiler in numpy.distutils; trying from distutils
error: Python was built with Visual Studio 2003;
extensions must be built with a compiler that can generate compatible  
Visual Studio 2003 was not found on this system. If you have Cygwin  
you can try compiling with MingW32, by passing "-c mingw32" to setup.py.

It appears that the mingw32 information isn't getting passed to  
distutils. I do indeed have a good installation of mingw32, as I can  
successfully build a related project that uses both C and Fortran  
extension modules via "python setup.py build -c mingw32".

If I just run "python c:\python25\Scripts\f2py.py", the help screen  
ends with:
Version:     2_5239
numpy Version: 1.1.0

Our Windows testing is very sporadic. I'm quite sure this worked a  
year ago, but I'm not sure when it broke.

Does anyone have any suggestions? Is this an actual bug, or am I  
using something incorrectly?


Ryan Gutenkunst
Biological Statistics and Computational Biology
Cornell University

More information about the Numpy-discussion mailing list