[Numpy-discussion] f2py from numpy 1.0.5 on OSX 10.4.11/QuadPPC fails with undefined symbols

Harry Mangalam harry.mangalam@uci....
Sun Mar 30 15:33:05 CDT 2008

Hi Robert,
thanks very much for your help - responses inline below.

On Friday 28 March 2008, Robert Kern wrote:
> Can you triple-check that the "unset LDFLAGS" worked by using
> env(1)? You still seem to have a -L/Users/hjm/lib flag that is
> obviously not coming from the command line.

$ env |grep LDFLAGS

That LDFLAGS was coming from my .profile and I've commented it out.

I just re-installed numpy (successfully, it seems) and re-tried the 
f2py command:

f2py --opt="-O3" -c -m fd_rrt1d --fcompiler=g95  --link-lapack_opt *.f

which results in an otherwise successful run except that the last few 
lines are identical to the one I posted before:

/usr/local/bin/g95 /tmp/tmp9hmmi5/tmp/tmp9hmmi5/src.macosx-10.3-ppc-2.5/fd_rrt1dmodule.o /tmp/tmp9hmmi5/tmp/tmp9hmmi5/src.macosx-10.3-ppc-2.5/fortranobject.o /tmp/tmp9hmmi5/CQZ.o /tmp/tmp9hmmi5/Umatrix1D.o /tmp/tmp9hmmi5/fd_rrt1d.o /tmp/tmp9hmmi5/tmp/tmp9hmmi5/src.macosx-10.3-ppc-2.5/fd_rrt1d-f2pywrappers.o -o ./fd_rrt1d.so -Wl,-framework -Wl,Accelerate
ld: Undefined symbols:

<many more but you get the idea>

However, the LDFLAGS was set when I installed a numpy via the ports 
system previously- could that have 'poisoned' the install by setting 
some variable that prevents finding the appropriate lib?

And do you know which lib is not being found?  I could just insert it 
into the final link command.


Harry Mangalam - Research Computing, NACS, E2148, Engineering Gateway, 
UC Irvine 92697  949 824 0084(o), 949 285 4487(c)
[A Nation of Sheep breeds a Government of Wolves.
Edward R. Murrow]

More information about the Numpy-discussion mailing list