[Numpy-discussion] Complete LAPACK needed (Frank Lagor)

Frank Lagor dfranci@seas.upenn....
Sat Nov 1 09:20:32 CDT 2008

Problem solved-- This posting is just to complete the thread to document it
if others have similar issues.

The previous error:
ImportError: liblapack.so: cannot open shared object file: No such file or

was solved simply by checking that the environment variables were set
properly.  I set BLAS, LAPACK, and LD_LIBRARY_PATH variables (I'm not sure
if the LD one was needed, but this worked)

The next issue I ran into was that the error message changed to "undefined
symbol _dgesdd",
which I googled and discovered was a routine for singular value
decomposition that was missing-- meaning that my liblapack.so file was
incomplete.  I checked this by doing
$ strings liblapack.so | grep dgesdd
and noticing that the output was blank.  The output was not blank however in
the lapack _LINUX.a install from the netlib lapack, so that meant that my
ATLAS install was incorrect.  I changed the way that I specified the
configure for ATLAS.  I had to use the --with-netlib-lapack option (as
stated in one of the installation files) instead of the "-Ss flapack
pathname" that is specified in the command line help.  Finally, the install

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20081101/147194a1/attachment.html 

More information about the Numpy-discussion mailing list