[Numpy-discussion] unable to build atlas and lapack correctly

Alexandre Lacoste alex.lacoste.ml@gmail....
Thu Oct 30 22:14:34 CDT 2008

Hi I'm trying to install numpy on a x86_64 ubuntu hardy and I'm having a
hard time to get atlas to be linked correctly.

Installing it through apt-get install with the astraw repository worked on
my intel dual core. But now I need to install it in on a x86_64 and the
astraw binaries will link against libatlas3gf-base instead of
libatlas3gf-3dnow because the 3dnow version simply doesn't exist for x86_64
arch. So I still get slow matrix multiplications ...

Then I went through the instructions for building atlas by hand. Then I
build numpy. Everything went ok... Now when comes the time to build scipy, I
get the following error :

from numpy.linalg import lapack_lite
ImportError: /usr/local/atlas/lib/liblapack.so: undefined symbol: ztbsv_

$ uname -a
Linux graal1 2.6.24-21-generic #1 SMP Mon Aug 25 16:57:51 UTC 2008 x86_64

$ ldd liblapack.so
        linux-vdso.so.1 =>  (0x00007fffe29fe000)
        libgfortran.so.2 => /usr/lib/libgfortran.so.2 (0x00007febd9ee3000)
        libm.so.6 => /lib/libm.so.6 (0x00007febd9c62000)
        libc.so.6 => /lib/libc.so.6 (0x00007febd98ff000)
        /lib64/ld-linux-x86-64.so.2 (0x00007febda93b000)

I'm getting clueless and googling for the error message return noting useful
any thoughts ?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20081030/7bb35960/attachment.html 

More information about the Numpy-discussion mailing list