[Numpy-discussion] unable to build atlas and lapack correctly

David Cournapeau david@ar.media.kyoto-u.ac...
Thu Oct 30 23:49:00 CDT 2008

Alexandre Lacoste wrote:
> Hi I'm trying to install numpy on a x86_64 ubuntu hardy and I'm having
> a hard time to get atlas to be linked correctly.
> Installing it through apt-get install with the astraw repository
> worked on my intel dual core. But now I need to install it in on a
> x86_64 and the astraw binaries will link against libatlas3gf-base
> instead of libatlas3gf-3dnow because the 3dnow version simply doesn't
> exist for x86_64 arch. So I still get slow matrix multiplications ...

You can simply use the sse2 version of atlas: SSE2 is available on any
x86_64 CPU.

Note that on Ubuntu, you can link to libatals3fg-base (the gfortran,
basic version of ATLAS), and after building numpy, installing atlas for
SSE2 and still get the speed up, thanks to the hwcap capability of the
GNU loader. The hwcap means that when the loaded code (numpy) request a
library (atlas), it will first look for a specially optimized one in
some directory (/usr/lib/sse2, for example), and will use the default
one if the optimized one is not there.

> Then I went through the instructions for building atlas by hand. Then
> I build numpy. Everything went ok... Now when comes the time to build
> scipy, I get the following error :
> from numpy.linalg import lapack_lite
> ImportError: /usr/local/atlas/lib/
> liblapack.so: undefined symbol: ztbsv_

You made a mistake when building lapack and/or atlas. Those are
difficult to build correctly, you should avoid build them by yourself as
much as possible,



More information about the Numpy-discussion mailing list