[Numpy-discussion] unable to build atlas and lapack correctly

Alexandre Lacoste alex.lacoste.ml@gmail....
Fri Oct 31 00:34:53 CDT 2008

Thanks for your answer

> You can simply use the sse2 version of atlas: SSE2 is available on any
> x86_64 CPU.

Are you sure ? I can't find it...

> Note that on Ubuntu, you can link to libatals3fg-base (the gfortran,
> basic version of ATLAS), and after building numpy, installing atlas for
> SSE2 and still get the speed up, thanks to the hwcap capability of the
> GNU loader. The hwcap means that when the loaded code (numpy) request a
> library (atlas), it will first look for a specially optimized one in
> some directory (/usr/lib/sse2, for example), and will use the default
> one if the optimized one is not there.

That's what I tried in the first place but I must have done something wrong
on that part too ;)

> You made a mistake when building lapack and/or atlas. Those are
> difficult to build correctly, you should avoid build them by yourself as
> much as possible,

I did it a couple of time in the past ... even on 64 bits machines... I
guess I was lucky back then.
I really need to get it work. I'll give it a couple of other tries. It is
only annoying to have to wait half an hour each time. If you can give me a
couple of other hints, maybe I'll target the problem faster.

Thanks again

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20081031/c56f0af1/attachment.html 

More information about the Numpy-discussion mailing list