[Numpy-discussion] building numpy locally but get error: undefined symbol: zgesdd_

Francis F.Drossaert@googlemail....
Wed Sep 17 04:27:29 CDT 2008

On Sep 17, 2:37 am, David Cournapeau <da...@ar.media.kyoto-u.ac.jp>
> Francis wrote:
> > To be frank, I am bit of noob, but not completely. I use the gfortran
> > make.inc to build lapack. The make.inc file to build and install atlas
> > is using gfortran.  I used the --fcompiler=gfortran flag. I don't
> > think there is much else I can do.
> Yes there is :) You should use --fcompiler=gnu95, not gfortran. That
> would explain the problem you had, actually. There is no problem being a
> noob: compiling numpy itself is easy, but unfortunately, its
> dependencies are not, and are almost systematically badly packaged by
> distributions. To make the situation worse, there are still two widely
> used gnu fortran compilers, which are ABI incompatible...

Even a noob can follow simple instructions. :) Tried gnu95 first and
then gfortran but both result in the same error.

> > Unfortunately there is no EPD installer for Centos 5 version. There
> > was a blog how to install it, but that look a lot more complicated
> > than what I am trying now.
> > I will try to build sage and look if I can build numpy against the
> > atlas libraries in sage. Otherwise I use sage and remove all the
> > packages that are not relevant for me, e.g. maxima, gap, singular,
> > etc.
> I am really sorry for all this trouble. The last solution you could try,
> with a bit old packages is my own repository, with Centos packages:
> http://download.opensuse.org/repositories/home:/ashigabou/CentOS_5/
> Install the numpy and scipy packages from there. There is also a src.rpm
> for atlas, which enables you to build atlas rpm automatically optimized
> for your CPU using one command (look at build atlas from ashigabou
> repository onwww.scipy.org/Installing_Scipy/Linux).
> I have been trying to update those packages yesterday, but some
> network-related problems prevented me from.

I can't open rpm files so I opened numpy with archive manager and
extracted Numpy to site-packages. Unfortunately importing numpy
results in ImportError: .... undefined symbol:
_PyUnicodeUCS4_IsWhitespace. Suggested solution found in wiki is to
hard-install numpy. Aaaaah ... it is like running in circles. Is it
possible to use refblas and lapack libraries in the ashigabou rep. to
hard-install numpy. Not sure what the site.cfg should look like than.

More information about the Numpy-discussion mailing list