[Numpy-discussion] "Can't install when cross-compiling"

Andrew Myers atmyers@berkeley....
Fri Apr 3 14:28:45 CDT 2009

Hello All,

I'm trying to install numpy 1.2.1 for 64-bit python 2.6.1 on Leopard.  
Python appears to have been installed correctly, and sys.maxint  
returns the 64 bit value. When I do

sudo python-64 setup.py config_fc --fcompiler=gnu95 install

I get the following error message:

running build_scripts
   adding 'build/scripts.macosx-10.5-universal-2.6/f2py64-64' to scripts
error: Can't install when cross-compiling

What's weird is that I've got this working once before, but after I  
tried to erase and re-install I started getting the error.

Chris Kees seems to have had this problem a few months back: http://www.nabble.com/Mac-OSX-4-way-universal-td18957309.html

He found that after erasing "Library/Frameworks/Python64.framework"  
the build worked correctly. Apparently having some remnant of a  
previous install on your system tricks the installer into thinking you  
are cross-compiling. However, removing that directory doesn't work for  

Any ideas?


More information about the Numpy-discussion mailing list