[Numpy-discussion] DVCS at PyCon

josef.pktd@gmai... josef.pktd@gmai...
Thu Apr 9 15:30:29 CDT 2009

On Thu, Apr 9, 2009 at 1:58 PM, Ondrej Certik <ondrej@certik.cz> wrote:
> On Thu, Apr 9, 2009 at 7:15 AM, Matthieu Brucher
> <matthieu.brucher@gmail.com> wrote:
>> 2009/4/9 David Cournapeau <cournape@gmail.com>:
>>> On Thu, Apr 9, 2009 at 10:38 PM, Matthieu Brucher
>>> <matthieu.brucher@gmail.com> wrote:
>>>> 2009/4/9 David Cournapeau <cournape@gmail.com>:
>>>>> On Wed, Apr 8, 2009 at 3:34 AM, Ondrej Certik <ondrej@certik.cz> wrote:
>>>>>> Yes.
>>>>> Do you have any windows developers (I am sorry, I am not familiar at
>>>>> all with sympy)?
>>>>> My main concern with git are:
>>>>>  - you may need the command line
>>>>>  - the index can be confusing (you can avoid learning it at first, but
>>>>> still some errors won't make sense before you get it).
>>>>>  - git is not discoverable (you need to read some documentation)
>>>> I tried to install git on my computer, as git-svn seemed so nice. I
>>>> tried git-svn and it told me that some .pm files are missing. Why did
>>>> it install git-svn if some files are missing? And why isn't it
>>>> possible to get some information on how to install those missing files
>>>> on the Internet.
>>> For which system did you install it ? I don't think git-svn work well
>>> or at all on windows.
>>> Otherwise, git has binary installers for every platform which matters.
>>> Installing from sources is a bit harder than bzr/hg, but certainly
>>> easier than svn, if you need to,
>> Installed from source on a RH4. It complains about missing SVN/Core.pm.
> One thing about git-svn is that this is not really needed if you just
> use git and I installed git from source on many linuxes and clusters
> and it just works, as it is just pure C. I usually just use git-svn on
> my laptop/workstation, where I install the Debian/Ubuntu packages, and
> I create the git repository, upload to github.com or somewhere else
> and just work with the git repository.
> But I agree that if it installs git-svn and it doesn't just work, it's
> a big problem.
> Ondrej
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion

git-svn is supposed to be available again on windows as part of
msysgit. I had it installed, but I didn't out git-svn. I removed
msysgit again since 1 GByte for this on my notebook with scarce drive
space was a waste. The installer version of git doesn't have git-svn

git citool  and git gui  look pretty good

In the file browser, I'm still missing change dates, tree view doesn't
have dates to quickly see which files got changed last,  e.g.


for the simple usage that I tried, the windows version seems to work
pretty well.

git clone --origin svn http://projects.scipy.org/git/scipy.git scipy

ends with

error: Failed connect to projects.scipy.org:80; No error (curl_result = 7, http_
code = 0, sha1 = 9e55c6b0809e66049f808448a2ce3a1131e318fe)
error: Unable to find 9e55c6b0809e66049f808448a2ce3a1131e318fe under http://proj
Cannot obtain needed commit 9e55c6b0809e66049f808448a2ce3a1131e318fe
while processing commit 7a429837e7ea88547711e5b3b5b9e38569fad553.
fatal: Fetch failed.

git clone   git://github.com/pv/scipy-work.git
worked without problems.

but just pushing  buttons on the gui is not enough

I created a branch but on my file system nothing happened. So I
started to read the tutorial, which says that all branches are in the
same directory. How can I edit files on the file system if I don't
know what branch I'm in?

Is there a way to have branches in different directories? I don't want
to have to start git all the time when I'm editing some files on a
branch?  I'm able to clone in a different directory, but I didn't see
an obvious way in the gui to link/compare with another clone.

I didn't manage to get a simple diff between two clones, and the error
messages are still "very" informative, e.g. response to failed fetch
in the gui is  "fatal: unable to fork" "Error: Command failed".

or on the command line: fetch seems to have worked but then (following
the tutorial:

C:\Josef\work-oth\!oth\testbranches\copyofpv>git log -p master..pv/master
fatal: ambiguous argument 'master..pv/master': unknown revision or path not in t
he working tree.

ok, finally a pull from one clone to another worked, I was confused
about the different branches in the same repository with different
names, but still no diff, ...


More information about the Numpy-discussion mailing list