[Numpy-discussion] Is this a bug in numpy.distutils ?

Matthew Brett matthew.brett@gmail....
Mon Aug 3 18:35:35 CDT 2009


We are using numpy.distutils, and have run into this odd behavior in windows:

I have XP, Mingw, latest numpy SVN, python.org python 2.6.  All the
commands below I am running from within the 'numpy' root directory
(where 'numpy' is a subdirectory).

If I run

python setup.py build

I get the following expected error:

No module named msccompiler in numpy.distutils; trying from distutils
error: Unable to find vccarsall.bat

because, I don't have MSVC.

If I run:

python setup.py build -c mingw32

- that works.  But. running

python setup.py build_ext -c mingw32

generates the same error as above.  Similarly:

python setup.py build_ext -c completely_unknown

Ignores the attempt to set the 'completely_unknown'  compiler, whereas

python setup.py build -c completely_unknown

raises a sensible error.  I conclude that the numpy.distutils
build_ext command is ignoring at least the compiler options.

Is that correct?

Thanks a lot,


More information about the NumPy-Discussion mailing list