[Numpy-discussion] Proposal for matrix_rank function in numpy
Wed Dec 16 13:15:06 CST 2009
On Wed, Dec 16, 2009 at 2:13 PM, Matthew Brett <email@example.com> wrote:
>>> Is it reasonable to summarize that, to avoid confusion, we keep
>>> 'matrix_rank' as the name?
>>> I've edited as Robert suggested, attempting to adopt a more suitable
>>> tone in the docstring...
>> What comes next when someone offers up a useful function like this?
>> We are using an earlier version of in statsmodels and wouldn't mind
>> seeing this in numpy. Presumably the doctests should be turned into
>> actual tests (noting Robert's comment) to make it more likely that it
>> gets in and an enhancement ticket should be filed?
> I'm happy to write the doctests as tests. My feeling is there is no
> objection to this function at the moment, so it would be reasonable,
> unless I hear otherwise, to commit to SVN.
Sounds good. I didn't know you had commit privileges, and I didn't
want to see this get lost in the shuffle.
More information about the NumPy-Discussion