[Numpy-discussion] Creating arrays with 'titles' in dtype causes TypeError on data access

Ralph Heinkel ralph@dont-mind...
Tue Feb 24 08:45:39 CST 2009


I'm trying to use the additional 'title' feature of dtypes when
creating arrays. The reason for using titles is that I want to store
meta data about the columns in them (so do-not-use-titles is not the
right solution for me...)

Everything works fine without titles:

>>> arr = array([('john', 4),('mark', 3)],
>>> arr[0]
('john', 4)
>>> arr[0][0]

However here something is strange:

>>> arr = array([('john', 4),('mark', 3)],
     dtype=[(('source:yy', 'name'),'O'),(('source:xx','id'),int)])
>>> arr[0]
('john', 4)
>>> arr[0][0]
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
TypeError: function takes at most 2 arguments (3 given)

Any ideas what I'm doing wrong? Any help would be appreciated.



- Python V 2.6 (but same error with python 2.5)
- Numpy 1.2.1  (but same error on numpy
- opensuse 10.3

More information about the Numpy-discussion mailing list