[Numpy-discussion] Complete LAPACK needed (Frank Lagor)

Jack Yu jackchungchiehyu@googlemail....
Wed Jan 14 13:57:50 CST 2009

Frank Lagor <dfranci <at> seas.upenn.edu> writes:

> Thanks so much for your help, David.  I'm sorry I did not receive your posts
previously -- I have the digest mode on and there is a bit of a delay.  I'll try
to change my options next time I post a request. 
> Thanks so much again,Frank
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion <at> scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion

I'm trying to run a python script in Condor(http://www.cs.wisc.edu/condor/) on a
cluster at uni. This script runs fine when I run it normally, just by typing
'python', followed by the name of the script.  However, after writing a condor
submission file for it, and submitting it as a condor job, it fails at the
importing of numpy, giving:
Traceback (most recent call last):
  File "/home/spxjcy/mycondor_stuff/CountApples/xCountApples.py", line 9, in <mo
    import numpy
  File "/opt/bin/python/lib/python2.5/site-packages/numpy/__init__.py", line 103
, in <module>
    import linalg
  File "/opt/bin/python/lib/python2.5/site-packages/numpy/linalg/__init__.py", l
ine 4, in <module>
    from linalg import *
  File "/opt/bin/python/lib/python2.5/site-packages/numpy/linalg/linalg.py", lin
e 29, in <module>
    from numpy.linalg import lapack_lite
ImportError: liblapack.so.3: cannot open shared object file: No such file or dir

After reading your thread, I realised that your problem was not the same, but
the closest I could find.  I tried 'numpy.test()', nothing fails.  On 'ldd
lapack_lite.so' I get:

        liblapack.so.3 => /usr/lib64/liblapack.so.3 (0x00002aaaaabd6000)
        libblas.so.3 => /usr/lib64/libblas.so.3 (0x00002aaaab1c2000)
        libg2c.so.0 => /usr/lib64/libg2c.so.0 (0x00002aaaab314000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaab435000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaab5bb000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaab6c7000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)

I'm not entirely sure what this means, but it looks like there is a file called

Another thing I have observed is that other modules which came with python like
'os', 're',etc. all import fine in condor, so I'm guessing that this is to do
with numpy on some part.  

Please, if you have any ideas about solving this, do say.  



More information about the Numpy-discussion mailing list