[Numpy-discussion] installation issue with a non-standard location of a python build

Daniel Wheeler daniel.wheeler2@gmail....
Tue Jul 28 10:38:47 CDT 2009


I'm having an installation issue building numpy 1.3.0 using python
2.6.2 which has been built in my local area in a non-standard place
and was configured with --prefix=/users/wd15/usr/i686/4.0. When I run
numpy's config ("python setup.py config") everything seems to be fine.
However, when I run "python setup.py build", it gives the following

   $ python --version
   Python 2.6.2

   $ uname -a
   Linux xxx.xxx.xxx 2.6.18-4-k7 #1 SMP Mon Mar 26 17:57:15 UTC 2007
i686 GNU/Linux

   $ python setup.py build
   Running from numpy source directory.
   non-existing path in 'numpy/distutils': 'site.cfg'
   F2PY Version 2


     File "numpy/core/setup.py", line 186, in check_types
       "Cannot compiler 'Python.h'. Perhaps you need to "\
   SystemError: Cannot compiler 'Python.h'. Perhaps you need to
install python-dev|python-devel.

Now, as I compiled python from source, "Python.h" is sitting neatly in
"/users/wd15/usr/i686/4.0/include/python2.6". The output from build
(not included above) even claims that the compile options point there:

    C compiler: gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv
-O3 -Wall -Wstrict-prototypes -fPIC

    compile options: '-Inumpy/core/src -Inumpy/core/include
-I/users/wd15/usr/i686/4.0/include/python2.6 -c'

so the build seems to be aware of the include location. Any ideas?


Daniel Wheeler

More information about the NumPy-Discussion mailing list