[Numpy-discussion] more on that missing directory

Sul, Young L Sul@hcp.med.harvard....
Fri Mar 20 15:19:02 CDT 2009

(I'm on a Solaris 10 intel system, and am trying to use the sunperf libraries)

I downloaded the 0.9.4 branch of numpy.scons.support, and tried to install from that.

An immediate problem is that some files seem to have embedded ^Ms in them. I had to clean and rerun a few times before numpy installed.

I tried to run the tests, but got the "0 tests run" message. In this case, none of the files had their execute bits set. If I ran each test individually, they seemed to pass, with the exception of one, which seems to be a known issue.

Now, I am trying to install scipy via numscons. It looked like it was going to work, but it barfed. From the output it looks like whatever is building the compile commands forgot to add the cc command at the beginning of the line (see below. I've highlighted the barf).

Can someone point me to the file that builds the commands? It seems like an easy fix.

 Executing scons command (pkg is scipy.interpolate): /usr/bin/python "/usr/lib/python2.4/site-packages/numscons/scons-local/scons.py" -f scipy/interpolate/SConstruct -I. scons_tool_path="" src_dir="scipy/interpolate" pkg_name="scipy.interpolate" log_level=50 distutils_libdir="../../../../build/lib.solaris-2.10-i86pc-2.4" cc_opt=/usr/lib/python2.4/pycc cc_opt_path="/usr/lib/python2.4" f77_opt=sunf77 f77_opt_path="/usr/bin" cxx_opt=/usr/lib/python2.4/pyCC cxx_opt_path="/usr/lib/python2.4" include_bootstrap=/usr/lib/python2.4/site-packages/numpy/core/include silent=0 bootstrapping=0
scons: Reading SConscript files ...
compiler suncc (lang CXX) has no configuration in /usr/lib/python2.4/site-packages/numscons/core/configurations/cxxcompiler.cfg => using default configuration.
Checking sunf77 C compatibility runtime ...(cached) -R/opt/SUNWspro/lib -L/opt/SUNWspro/lib -L/opt/SUNWspro/prod/lib -L/usr/ccs/lib -L/lib -L/usr/lib -lfui -lfai -lfsu -lsunmath -lmtsk -lm
scons: done reading SConscript files.
scons: Building targets ...

#######HERE IS THE ERROR#######
o build/scons/scipy/interpolate/src/so__interpolate.o -c -KPIC -I/usr/lib/python2.4/site-packages/numpy/core/include -I/usr/include/python2.4 -I/usr/lib/python2.4/site-packages/numpy/f2py/src build/scons/scipy/interpolate/src/_interpolate.cpp
sh: o: not found
#######HERE IS THE ERROR#######

CC -o build/scons/scipy/interpolate/_interpolate.so -G build/scons/scipy/interpolate/src/so__interpolate.o -Lbuild/scons/scipy/interpolate -R/opt/SUNWspro/lib -L/opt/SUNWspro/lib -L/opt/SUNWspro/prod/lib -L/usr/ccs/lib -L/lib -L/usr/lib -lfui -lfai -lfsu -lsunmath -lmtsk -lm
ld: fatal: file build/scons/scipy/interpolate/src/so__interpolate.o: open failed: No such file or directory
ld: fatal: File processing errors. No output written to build/scons/scipy/interpolate/_interpolate.so
scons: *** [build/scons/scipy/interpolate/_interpolate.so] Error 1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090320/1ac2ba2b/attachment.html 

More information about the Numpy-discussion mailing list