[Numpy-discussion] Built Lapack, Atlas from source.... now numpy.linalg.eig() hangs at 100% CPU

David Cournapeau david@ar.media.kyoto-u.ac...
Fri Mar 27 09:12:33 CDT 2009

Chris Colbert wrote:
> Hey Everyone,
> I built Lapack and Atlas from source last night on a C2D running
> 32-bit Linux Mint 6.  I ran 'make check' and 'make time' on the lapack
> build, and ran the dynamic LU decomp test on atlas. Both packages
> checked out fine.
> Then, I built numpy and scipy against them using the appropriate flags
> in site.cfg for the parallel thread atlas libraries. This seems to
> have worked properly as numpy.dot() utilizes both cores at 100% on
> very large arrays. I have also done id(numpy.dot) and
> id(numpy.core.multiarray.dot) and verified that the two ids are
> different.
> So I believe the build went properly. The problem I am having now is
> that numpy.linalg.eig (and the eig functions in scipy) hang at 100%
> CPU and never returns (no matter the array size). Numpy.test() hung as
> well, I'm assuming for this same reason. I have included the
> configurations below. Any idea what would cause this?

What does numpy.test() returns ? This smells like a fortran runtime problem,



More information about the Numpy-discussion mailing list