[Numpy-discussion] Built Lapack, Atlas from source.... now numpy.linalg.eig() hangs at 100% CPU

Chris Colbert sccolbert@gmail....
Fri Mar 27 10:20:22 CDT 2009

I built Atlas 3.8.3 which I assume is the newest release.


2009/3/27 Charles R Harris <charlesr.harris@gmail.com>

> 2009/3/27 Chris Colbert <sccolbert@gmail.com>
>> Hey Everyone,
>> I built Lapack and Atlas from source last night on a C2D running 32-bit
>> Linux Mint 6.  I ran 'make check' and 'make time' on the lapack build, and
>> ran the dynamic LU decomp test on atlas. Both packages checked out fine.
>> Then, I built numpy and scipy against them using the appropriate flags in
>> site.cfg for the parallel thread atlas libraries. This seems to have worked
>> properly as numpy.dot() utilizes both cores at 100% on very large arrays. I
>> have also done id(numpy.dot) and id(numpy.core.multiarray.dot) and verified
>> that the two ids are different.
>> So I believe the build went properly. The problem I am having now is that
>> numpy.linalg.eig (and the eig functions in scipy) hang at 100% CPU and never
>> returns (no matter the array size). Numpy.test() hung as well, I'm assuming
>> for this same reason. I have included the configurations below. Any idea
>> what would cause this?
> This is a problem that used to turn up regularly and was related to the
> atlas build. The atlas version can matter here, but I don't know what the
> currently recommended atlas version is.
> Chuck
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20090327/cce0302a/attachment-0001.html 

More information about the Numpy-discussion mailing list