[Numpy-discussion] bus error in embedded numpy

Pauli Virtanen pav+sp@iki...
Fri Nov 13 13:26:23 CST 2009

Fri, 13 Nov 2009 19:12:26 +0000, Robin wrote:
> How does the RTLD_GLOBAL thing manifest itself? So far I have only a
> very basic start which basically consists of:
>     cmd = mxArrayToString(prhs[0]);
>     PyRun_SimpleString(cmd);
> but I haven't noticed anything not working - I can run numpy testsuite,
> and do simple commands as expected (initiliase arrays in the
> interpreter, run numpy functions on them). Perhaps recent versions of
> Matlab behave differently (I am using R2009a on a mac).

The RTLD_GLOBAL issue prevented Numpy from being imported. I think 
everything was well, until you tried to run "import numpy" in the 
embedded process -- loading multiarray.so would fail because of missing 

But if it worked for you without the hack, then it must have been changed 
in the Matlab versions since then (and Pythoncall needs updating...).

Pauli Virtanen

More information about the NumPy-Discussion mailing list