[Numpy-discussion] Installing numpy with MKL

Benjamin Root ben.root@ou....
Tue Aug 3 18:19:27 CDT 2010

On Tue, Aug 3, 2010 at 3:31 PM, Søren Gammelmark <gammelmark@phys.au.dk>wrote:

> I feel a bit silly :-)
> The compile now appear to work. Sort of. I discovered I had sneaken in a
> "pthreads" in the mkl_libs line, which is obviously not in the
> mkl-directory (I had stolen this line from a stand-alone program I wrote
> at some point). The error message is a bit confusing though - the python
> setup.py-script seems to claim that none of the libraries are there.
> In any case the compile works now. However, when I try to run the python
> tests, python crashes because it cannot find libmkl_def.so. This is
> weird because LD_LIBRARY_PATH is set correctly. I also tried compiling
> with LD_RUN_PATH=$MKLROOT/lib/em64t but to no avail. I then tried adding
> mkl_def to the mkl_libs-line and now it works. However, I seem to recall
> reading somewhere that this is not a good idea. I guess that this is
> related to what your referred post was about? Did you end up using the
> patch or have you found a less invasive method since?
> Now on to SciPy... :-)
> Thankyou for your help
> Søren
I wouldn't know for sure, but could this be related to changes to the gcc
compiler in Fedora 13 (with respect to implicit DSO linking) or would that
only be an issue at build-time?


Ben Root
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100803/fd18d330/attachment.html 

More information about the NumPy-Discussion mailing list