[Numpy-discussion] still having numpy installation issues

martin djokovic martin.djokovic@gmail....
Mon Aug 23 14:37:54 CDT 2010

I tried to find all the numpy locations and removed them then tried....

 yum install numpy

 After trying for s few minutes.......got the following

 Error: Cannot find a valid baseurl for repo: extras

 If I install the other way using the tar file ...I still get

 >>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/local/lib/python2.4/site-packages/numpy/__init__.py",
line 144, in ?
    import fft
  File "/usr/local/lib/python2.4/site-packages/numpy/fft/__init__.py",
line 4, in ?
    from fftpack import *
  File "/usr/local/lib/python2.4/site-packages/numpy/fft/fftpack.py",
line 28, in ?
    import fftpack_lite as fftpack
ImportError: /usr/local/lib/python2.4/site-packages/numpy/fft/fftpack_lite.so:
undefined symbol: vmldCos2

 I tried looking for missing libraries using...

ldd fft/fftpack_lite.so

No libraries missing......

linux-gate.so.1 => (0x0060d000)

libimf.so => /opt/intel/fc/9.1/lib/libimf.so (0x0025e000)

libm.so.6 => /lib/libm.so.6 (0x00110000)

libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00bad000)

libirc.so => /opt/intel/fc/9.1/lib/libirc.so (0x00ecc000)

libc.so.6 => /lib/libc.so.6 (0x0049c000)

libdl.so.2 => /lib/libdl.so.2 (0x008fd000)

/lib/ld-linux.so.2 (0x00243000)

checked the path to python for both root and user-made an alias in both to
refer to same python

 Nothing seems to work-if you guys have any more ideas I would love to hear
them-I am stuck here amd cannot move ahead and no one in my office who can
help-so your help is much appreciated.

I am also wondering if you need to scipy or biopython to use numpy???
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100823/cd506f58/attachment-0001.html 

More information about the NumPy-Discussion mailing list