[Numpy-discussion] 1.4.0 installer fails on OSX 10.6.2

Christopher Barker Chris.Barker@noaa....
Tue Jan 5 16:09:14 CST 2010

Eric Firing wrote:
>> I'm having an odd problem with the package installer for numpy 1.4.0.
>> It complains:
>> numpy 1.4.0 can't be installed on this disk. numpy requires System
>> Python 2.6 to install.
> I think the problem is that the message is misleading; it should be 
> saying you need python from python.org, *not* the python that comes with 
> OSX.

yes, that is it the "system python" referred to in the error message is 
actually the "python.org Framework build".

I recommend it anyway, it's newer, and you won't accidentally mess with 
anything Apple is doing.


Christopher Barker, Ph.D.

Emergency Response Division
NOAA/NOS/OR&R            (206) 526-6959   voice
7600 Sand Point Way NE   (206) 526-6329   fax
Seattle, WA  98115       (206) 526-6317   main reception


More information about the NumPy-Discussion mailing list