[Numpy-discussion] Numpy 1.5 for Python 2.7 and 3.1

Christoph Gohlke cgohlke@uci....
Fri Jun 25 14:31:36 CDT 2010

Dear NumPy developers,

at <http://projects.scipy.org/numpy/ticket/1520> I have posted a patch 
against numpy svn trunk r8464 that:

1) removes the datetime functionality
2) restores ABI compatibility with numpy 1.4.1
3) enables numpy to build and run on Python 2.7 and 3.1 (at least on 

I hope this work can be used to get a numpy 1.5.x branch started.

Regarding Python 2.7, which is scheduled to be released within 2 weeks: 
numpy 1.4.1 does build and work with minor changes 
(http://projects.scipy.org/numpy/changeset/7926 and followups). However, 
for Python 2.7, the proposed patch will not be binary compatible with 
numpy 1.4.1 because it uses PyCapsule instead of PyCObject.



More information about the NumPy-Discussion mailing list