[Numpy-discussion] Schedule for 1.5.1?
Fri Oct 8 12:28:01 CDT 2010
On Fri, Oct 8, 2010 at 1:10 PM, Pauli Virtanen <firstname.lastname@example.org> wrote:
> Fri, 08 Oct 2010 10:48:14 -0600, Charles R Harris wrote:
>> On Fri, Oct 8, 2010 at 10:37 AM, <email@example.com> wrote:
>>> Ok I remember, Pareto is actually Lomax or Pareto second kind, and
>>> should be renamed. The proposal was to rename the current pareto to
>>> pareto2 and create a new pareto that corrects location by one.
>>> In the meantime I discovered that Lomax is actually nicer to work with
>>> than Pareto one, so it's mainly a question of terminology/names and
>>> documentation. Just calling it pareto is very misleading.
>> That doesn't sound like something for 1.5.1. Can you think through the
>> naming issue and open a ticket so we can start rationalizing this for
>> 2.0? I'm thinking having pareto1 and lomax, or maybe pareto1 and
>> pareto2, and deprecating plain old pareto may be the way to go.
> The documentation bit can be done, however, if there's a plan how to deal
> with it.
I think I clarified the doc string enough that user that read the
docstring don't get confused anymore.
At least the first part is explicit about it, the notes refer to
pareto in general or pareto 1 (formula is for pareto 1)
> Pauli Virtanen
> NumPy-Discussion mailing list
More information about the NumPy-Discussion