[Numpy-discussion] Pthreads ATLAS

Andreas Kloeckner lists@informa.tiker....
Mon Sep 6 14:03:50 CDT 2010

Hi all,

I've just tried to set up a Python 3 test environment for me to begin
porting PyCUDA and PyOpenCL to Python 3, but numpy installation managed
to foil my. I'm on Debian, and I believe that Debian purposefully
compiles ATLAS without pthreads support. Whenever I build numpy 1.5, I
encounter this error:

Python 3.1.2 (release31-maint, Jul  8 2010, 09:18:08) 
[GCC 4.4.4] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/andreas/src3/lib/python3.1/site-packages/numpy/__init__.py", line 136, in <module>
    from . import add_newdocs
  File "/home/andreas/src3/lib/python3.1/site-packages/numpy/add_newdocs.py", line 9, in <module>
    from numpy.lib import add_newdoc
  File "/home/andreas/src3/lib/python3.1/site-packages/numpy/lib/__init__.py", line 13, in <module>
    from .polynomial import *
  File "/home/andreas/src3/lib/python3.1/site-packages/numpy/lib/polynomial.py", line 17, in <module>
    from numpy.linalg import eigvals, lstsq
  File "/home/andreas/src3/lib/python3.1/site-packages/numpy/linalg/__init__.py", line 48, in <module>
    from .linalg import *
  File "/home/andreas/src3/lib/python3.1/site-packages/numpy/linalg/linalg.py", line 23, in <module>
    from numpy.linalg import lapack_lite
ImportError: /home/andreas/src3/lib/python3.1/site-packages/numpy/linalg/lapack_lite.so: undefined symbol: ATL_dptsyrk

I gather that "pt" in the symbol name means that this is a
pthreads-accelerated version of dsyrk. How do I convey to numpy that I
don't have (nor want) Pthreads-accelerated ATLAS bits? Failing that, how
do I tell it to just not use ATLAS?

I tried looking for information at

- numpy-1.5.0/doc/source/user/install.rst
- http://docs.scipy.org/doc/ 
- http://new.scipy.org/building/linux.html
- http://www.scipy.org/Installing_SciPy/Linux

but nothing seemed to apply, and Google only gave me an instance of
Skipper Seabold asking the same question (apparently when building his
own Atlas) only to reply with a somewhat opaque "I figured it out"

Thanks in advance,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100906/9bb0b4fe/attachment.bin 

More information about the NumPy-Discussion mailing list