[Numpy-discussion] SVD does not converge on "clean" matrix

Nadav Horesh nadavh@visionsense....
Thu Aug 11 09:21:09 CDT 2011

Had no problem on a gentoo 64 bit machine using atlas 3.8.0 (Core I7, python 2.7.2, numpy versions1.60 and 1.6.1)

From: numpy-discussion-bounces@scipy.org [numpy-discussion-bounces@scipy.org] On Behalf Of dhanjal@telecom-paristech.fr [dhanjal@telecom-paristech.fr]
Sent: 11 August 2011 16:23
To: numpy-discussion@scipy.org
Subject: [Numpy-discussion] SVD does not converge on "clean" matrix

Hi all,

I get an error message "numpy.linalg.linalg.LinAlgError: SVD did not
converge" when calling numpy.linalg.svd on a "clean" matrix of size (1952,
895). The matrix is clean in the sense that it contains no NaN or Inf
values. The corresponding npz file is available here:

Here is some information about my setup: I use Python 2.7.1 on Ubuntu
11.04 with numpy 1.6.1. Furthermore, I thought the problem might be solved
by recompiling numpy with my local ATLAS library (version 3.8.3), and this
didn't seem to help. On another machine with Python 2.7.1 and numpy 1.5.1
the SVD does converge however it contains 1 NaN singular value and 3
negative singular values of the order -10^-1 (singular values should
always be non-negative).

I also tried computing the SVD of the matrix using Octave 3.2.4 and Matlab (R2010a) 64-bit (glnxa64) and there were no problems. Any help
is greatly appreciated.

Thanks in advance,

NumPy-Discussion mailing list

More information about the NumPy-Discussion mailing list