[Numpy-discussion] Adding an axis argument to numpy.unique

Stéfan van der Walt stefan@sun.ac...
Tue Aug 20 03:51:48 CDT 2013

On Tue, Aug 20, 2013 at 2:39 AM, Joe Kington <joferkington@gmail.com> wrote:
> That's certainly a potential source of confusion.  However, I can't seem to
> come up with a better name for the kwarg. Matlab's "unique" function has a
> "rows" option, which is probably a more intuitive name, but doesn't imply
> the expansion to N-dimensions.

To me, `unique_rows` sounds perfect.  To go along columns: unique_rows(A.T)


More information about the NumPy-Discussion mailing list