[Numpy-discussion] New numpy functions: filled, filled_like

Benjamin Root ben.root@ou....
Mon Jan 14 11:33:52 CST 2013

On Mon, Jan 14, 2013 at 12:27 PM, Eric Firing <efiring@hawaii.edu> wrote:

> On 2013/01/14 6:15 AM, Olivier Delalleau wrote:
> > - I agree the name collision with np.ma.filled is a problem. I have no
> > better suggestion though at this point.
> How about "initialized()"?

A verb! +1 from me!

For those wondering, I have a personal rule that because functions *do*
something, they really should have verbs for their names.  I have to learn
to read functions like "ones" and "empty" like "give me ones" or "give me
an empty array".

Ben Root
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20130114/9b8d6d7e/attachment.html 

More information about the NumPy-Discussion mailing list