[Numpy-svn] [numpy/numpy] 3692b1: API: Rename 'niter' to 'nop' in the nditer

noreply@githu... noreply@githu...
Fri Mar 18 00:23:31 CDT 2011

Branch: refs/heads/master
Home:   https://github.com/numpy/numpy

Commit: 3692b16d8a844c0c042af7c27e7cef93170ea37d
Author: Mark Wiebe <mwwiebe@gmail.com>
Date:   2011-03-17 (Thu, 17 Mar 2011)

Changed paths:
  M doc/source/reference/c-api.iterator.rst
  M numpy/add_newdocs.py
  M numpy/core/code_generators/numpy_api.py
  M numpy/core/src/multiarray/nditer.c.src
  M numpy/core/src/multiarray/nditer_pywrap.c
  M numpy/core/src/umath/ufunc_object.c

Log Message:
API: Rename 'niter' to 'nop' in the nditer

This name was chosen partially based on the previous multi-iter,
which stored an array of iterators, so 'niter' made sense. In the
new nditer, it doesn't, and 'nop' for number of operands seems better.

More information about the Numpy-svn mailing list