[SciPy-dev] Compilation status on Solaris 8

Tim Lahey tjlahey at mud.cgl.uwaterloo.ca
Mon Apr 8 13:06:41 CDT 2002


With the various changes in CVS, I've finally got to the compilation
stage on Solaris 8.

I run into the following error if I compile with cc (Sun Workshop):
(Modified for email formatting)
building 'cephes' library
cc -DNDEBUG -O -c /u/tjlahey/devel/scipy/special/cephes/kolmogorov.c
-o build/temp.solaris-2.8-sun4u-2.2/kolmogorov.o
"scipy/special/cephes/mconf.h", line 114: missing operator
"scipy/special/cephes/protos.h", line 41: syntax error before or at: /
"scipy/special/cephes/kolmogorov.c", line 40: warning: division by 0
"scipy/special/cephes/kolmogorov.c", line 146: cannot recover from
previous errors

if I just try to compile with gcc:
gcc -DNDEBUG -O -c scipy/special/cephes/kolmogorov.c
-o build/temp.solaris-2.8-sun4u-2.2/kolmogorov.o

In file included from scipy/special/cephes/kolmogorov.c:26:
/u/tjlahey/devel/scipy/special/cephes/mconf.h:122: parse error

In both cases the mconf error is the same error just reported differently.
This code is checking for various defines to determine if it is big-endian.
Likely why it hasn't been found before.

The protos.h error is due to a C++ style comment in a C file (// vs. /**/)
as the Sun compiler is a C compiler (one uses c++ to compile C++ code).
So this is a result of a picky compiler (but one that adheres to the

Suggestions ?



More information about the Scipy-dev mailing list