[SciPy-dev] weave errors with python/gcc-3.0.3 and scipy/gcc-2.95.3

pearu at scipy.org pearu at scipy.org
Mon Apr 8 14:23:24 CDT 2002

On Mon, 8 Apr 2002, eric wrote:

> > ImportError: undefined symbol: __gxx_personality_v0
> >
> ???.  Never seen anything like this before.  Is that symbol defined in
> libpython.a?  If so, then I'm betting it came from 3.0.3, and the 2.95.3
> compiler is not picking up the correct library.

This symbol __gxx_personality_v0 is defined in libsupc++ that comes with

> Have you  tried building another extension (say something from scipy) with
> 2.95.3?  If that works with your gcc 3.x python, then we'll have to start
> looking through weave.  It could also have something to do with g++ vs. gcc
> issues in the 2.x to 3.x transition.  I don't think it is a python22 issue.

All other (non C++) extensions work fine with various compilers like
2.95.2,, 2.95.3. I have spend half a day trying to downgrade gcc
3.x to gcc 2.95.x without success. I think I have tried everything except
reinstalling the whole Suse distribution (unfortunately I don't have a 
root  access for this:(), but from some place this symbol sneaks in when
compiling/linking C++ stuff. 
It seems that I am stuck with gcc-3.x. Not sure if this is good or bad,
but certainly inconvinient right now: cannot test weave on this fast
machine with enough memory...


More information about the Scipy-dev mailing list