[SciPy-dev] Argh!! Still the same error after 1 year

Rob rob at pythonemproject.com
Sat Dec 7 11:52:28 CST 2002

Hi Eric,

I can't believe you haven't fixed the FreeBSD problem that I pointed out
a year ago.  My website will be in IEEE A&P Magazine in December I
wanted to update the Weave section and promote SciPy.  But I'm still
getting the same error message I got a year ago on FreeBSD:

Traceback (most recent call last):
  File "/home/rob/published/xyzfdtd-weave/xyzfdtd-weave.py", line 672,
in ?
  File "/usr/local/lib/python2.2/site-packages/weave/blitz_tools.py",
line 99, in blitz
    type_factories = blitz_type_factories,
  File "/usr/local/lib/python2.2/site-packages/weave/inline_tools.py",
line 432, in compile_function
    exec 'import ' + module_name
  File "<string>", line 1, in ?
Undefined symbol "cerr"

Cerr, the bane of my weave attempts.  In the past I had to hack my Weave
source code to inlcude std++ library to get rid of this.

Please fix it, so  I can include Blitz'd code on my web site.

Thanks,  Rob.
The Numeric Python EM Project


More information about the Scipy-dev mailing list