[SciPy-dev] Stupid question.

Fernando Pérez fperez at pizero.colorado.edu
Tue Feb 19 14:15:26 CST 2002

> More than that, it was working before right?  From the command line link
> statement you sent, it looks like it *should* link.  If you type it at the
> command line does it work?  Maybe add -L/usr/local/lib and see if that helps?

Already tried that, and it makes no difference. And yes, I tried the
gcc... command on its own at the cmd line and I get the same. I've rerun
ldconfig (as root), /usr/local/lib is in /etc/ld.so.conf, and as I said, an
ldconfig -p reports the fft libs fine:

root[/etc]# ldconfig -p | grep fftw
        libsrfftw_threads.so.2 (libc6) =>
        libsrfftw.so.2 (libc6) => /usr/local/lib/libsrfftw.so.2
        libsfftw_threads.so.2 (libc6) => /usr/local/lib/libsfftw_threads.so.2
        libsfftw.so.2 (libc6) => /usr/local/lib/libsfftw.so.2
        librfftw_threads.so.2 (libc6) => /usr/local/lib/librfftw_threads.so.2
        librfftw.so.2 (libc6) => /usr/local/lib/librfftw.so.2
        libfftw_threads.so.2 (libc6) => /usr/local/lib/libfftw_threads.so.2
        libfftw.so.2 (libc6) => /usr/local/lib/libfftw.so.2

Is there a version number issue at play here? Do I need to make 'naked'
symlinks to all  these without the .2 numbers?

I'll try that and see what happens.

All help appreciated,


More information about the Scipy-dev mailing list