[SciPy-dev] Stupid question.

eric eric at scipy.org
Tue Feb 19 13:18:54 CST 2002

Hey Fernando,

Come to think of it, I don't think I've ever linked SciPy against shared
versions of these libraries.  I've always linked against libxxx.a versions.  Do
you have these laying around so that you can test against them?


----- Original Message -----
From: "Fernando Pérez" <fperez at pizero.colorado.edu>
To: <scipy-dev at scipy.org>
Sent: Tuesday, February 19, 2002 3:15 PM
Subject: Re: [SciPy-dev] Stupid question.

> > More than that, it was working before right?  From the command line link
> > statement you sent, it looks like it *should* link.  If you type it at the
> > command line does it work?  Maybe add -L/usr/local/lib and see if that
> Already tried that, and it makes no difference. And yes, I tried the
> gcc... command on its own at the cmd line and I get the same. I've rerun
> ldconfig (as root), /usr/local/lib is in /etc/ld.so.conf, and as I said, an
> ldconfig -p reports the fft libs fine:
> root[/etc]# ldconfig -p | grep fftw
>         libsrfftw_threads.so.2 (libc6) =>
> /usr/local/lib/libsrfftw_threads.so.2
>         libsrfftw.so.2 (libc6) => /usr/local/lib/libsrfftw.so.2
>         libsfftw_threads.so.2 (libc6) => /usr/local/lib/libsfftw_threads.so.2
>         libsfftw.so.2 (libc6) => /usr/local/lib/libsfftw.so.2
>         librfftw_threads.so.2 (libc6) => /usr/local/lib/librfftw_threads.so.2
>         librfftw.so.2 (libc6) => /usr/local/lib/librfftw.so.2
>         libfftw_threads.so.2 (libc6) => /usr/local/lib/libfftw_threads.so.2
>         libfftw.so.2 (libc6) => /usr/local/lib/libfftw.so.2
> Is there a version number issue at play here? Do I need to make 'naked'
> symlinks to all  these without the .2 numbers?
> I'll try that and see what happens.
> All help appreciated,
> f
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev

More information about the Scipy-dev mailing list