[SciPy-dev] Stupid question.

Fernando Pérez fperez at pizero.colorado.edu
Wed Feb 20 11:41:57 CST 2002

On Wed, 20 Feb 2002, Prabhu Ramachandran wrote:

> I know that this problem has been solved but FWIW everything seems to
> work fine under Woody Debian GNU/Linux.

If you have extra pointers, I've posted some instructions on this topic at 

Feel free to comment/fix or add information about what may be different for
other distros. I think the easier we can make life for those willing to use
cvs, the better off we'll be in the long run.

> However, at the moment my scipy install seems to have gone crazy.  The
> stats module or the ga module seems badly broken.  I cant seem to
> import scipy anymore.  I blindly changed all import scipy.stats.rv as
> rv lines to import scipy.stats.rv in the ga directory (in my installed
> copy) and now scipy seems to load ok.
> scipy.test() however does not work anymore.
> In [1]: import scipy
> scip
> In [2]: scipy.test()
> ---------------------------------------------------------------------------
> TypeError                                 Traceback (most recent call last)
> ? 
> ? in test(level=1)
> ? in test_suite(level=1)
> TypeError: harvest_test_suites() got an unexpected keyword argument 'level'
> I guess it serves me right to keep updating from CVS and trying. :(

Why don't you try a clean rebuild/install?

cd your_scipy_cvs/
rm -rf build
./setup.py build
pushd /usr/lib/python/site-packages/
rm -rf scipy*
./setup.py install

and see what happens? That worked for me as of yesterday's code.

Good luck,


More information about the Scipy-dev mailing list